Apalis iMX6 eclipse debug error

I’m Working on a Virtual Machine with Ubuntu 18.04.2 mounted, the host OS is Windows 10.

I’m following the Getting started guide to setup Eclipse on my Ubuntu VM and I get an error after preparing all the settings and I have to debug.

The steps I have followed to reach this state are the following:

  1. Change Dash to Bash following this
  2. Configured the toolchain 2.7 and enviromental variables
  3. Instaled Java 1.8.0_201
  4. Installed The latest version of Eclipse Neon 3 c++/c for linux 64
  5. Configured all the settings for building and debugging found on the guide

After all the preparations, when the program is ready to be debugged I get a problem that appears the first time, as discussed in other queries, the program should be working fine afterwards but instead the process of debugging gets stuck at either 96% or 97% and after a while it responds this error message:

Error in final launch sequence
    Failed to execute MI command:
    -target-select remote
Error message from debugger back end: Connection timed out. Connection timed out.

And this is the console text:

gdbserver  :2345 /home/root/hello-world-debug;exit

Last login: Tue Apr  9 14:32:05 2019 from

root@apalis-imx6:~# gdbserver  :2345 /home/root/hello-world-debug;exit
Process /home/root/hello-world-debug created; pid = 955
Listening on port 2345 is the IP of Apalis iMX6 ethernet connection and 2345 is the number of the port that was chosen by default.

I have reproduced this error on another computer using an Ubuntu 18.04 build as a host and conected to the same network.

Also, the project that I try to debug gets loaded to the Apalis as Eclipse is trying to debug, and afterwards I can run it succsessfully.

Any idea of what could be causing this?

hi @AlexPG

Have you done any changes to the Software (kernel, devicetree, …)?

Concerning your Issue: What is the topology of your network?
Is the Port 2345 open in your router/windows firewall?

best regards,

Perfect, that it works. Thanks for the feedback.

Hello @jaski.tx

I have solved the issue, the problem was in the network. The ip of the Apalis was isolated from the other devices and couldn’t establish a connection, once we linked both networks the debugger worked as supposed.

Thanks for the assistance