Apalis i.MX8 SD Boot

We have an Apalis 1.1 evaluation board and an i.MX8QP module. I used EasyInstaller to program a custom built 6.4 TorizonOs image. The board boots fine.

I am, however, now unable to replace the module image. Recovery fails “Waiting for USB device to appear”. This has once in the past with other image combinations so I think the connection is ok.

Booting from SD using EasyInstaller 5.7.3 fails with “udp, unknown command”. This worked previously. I used this method to replace easy installer so I could program the current OS image.

My question: Is there a dependency on what is programmed into eMMC0 when trying to recover with SD? I have seen some suggestions that Tezi needs to be at the same version as Torizon OS. I haven’t been able to find a 6.x Tezi build. If this is the issue, where can i get the 6.x Tezi?

Loading Toradex Easy Installer from an External Media (SD Card/USB Stick) is an alternative method, not officially supported by Toradex, as we technically cannot guarantee that this works all the time and also across different versions. This method relies on Distro Boot, and require fully functioned U_boot be present at eMMC.

Matching the versions of Tezi and the BSP is not mandatory. However, if you use mismatched versions, things may still work, but with a lower likelihood of success. You might need to adapt the boot.scr to ensure functionality.

The recommended and supported method for loading TEZI is through USB OTG. For detailed instructions, please refer to this article.

That was what I tried first. From both Linux and windows I get:

uuu (Universal Update Utility) for nxp imx chips – libuuu_1.4.127-0-g08c58c9

Success 0 Failure 0 Wait for Known USB Device Appear…

And it hangs indefinitely. What are my options if this won’t work. Can I simply flash eMMC?

Have you put the Apalis module into recovery mode as described here? Do you have a USB cable connected between the X49 or X50 on Apalis Evaluation board and your host machine? If so please try shorter and better quality USB cable .

This worked previously. I had used the erase feature in the Tezi GUI to clear memory and was able to restore using the usb cable. That’s why I was asking about a dependency on what is flashed in eMMC. I can at least boot at the moment and have access to uboot. I thought about clearing memory with uboot in hopes that the usb approach would work again. Of course if that doesn’t work I am really dead in the water.

I will try some other cables.

Any idea why Booting from SD using EasyInstaller 5.7.3 fails with “udp, unknown command”.

Sorry , not enough data. Could you please provide more detailed information, including a boot log?"

Loading the Toradex Easy Installer in recovery mode via USB OTG is independent of the current eMMC content, as it is loaded and executed solely in RAM.

I finally found that erasing mmc 0:1 is required before the OTG connection becomes active in windows. Clunky but it works.