Apalis and ROS Support

Has there been any attempts by the Toradex team to install ROS on either the Apalis T30 or the Apalis TK1?

We have a customer who is wanting to use ROS for part of a subsea application and has asked us to investigate this matter with our custom TK1 and carrier board.

As far as I can find, the NVIDIA Jetson TK1 platform has instructions for installing ROS around JetPack with L4T:

http://wiki.ros.org/NvidiaJetsonTK1

I’m guessing that the installation would be just as straightforward for the Apalis TK1, following on from these instructions?

http://developer.toradex.com/knowledge-base/installing-nvidia-jetpack-with-l4t-on-apalis-tk1

I don’t think we ever tried ROS much so far at Toradex. However your assumption should be correct and at least on Apalis TK1 one should be able to install it just like on Jetson TK1 after having done the JetPack installation as per my article. Alternatively there exists a ROS Yocto layer as well but we also have neither tried building nor running that one as far as I know.

Just as Marcel said, you can use ROS Yocto layers to generate ROS for TK1 if not using JetPack. We compiled it based on our Linux BSP V2.5(Yocto codename is fido) before. Add '${TOPDIR}/…/stuff/meta-ros ’ to ‘conf/bblayers.conf’ and add 'IMAGE_INSTALL_append = “roslaunch” ’ to ‘conf/local.conf’. If you need full package of ROS, then use 'IMAGE_INSTALL_append = “packagegroup-ros-world” ’ instead. The host machine for buiding image by OpemEmedded should have 8GB memory, there is out of memory error on 4GB memory. And it will take hours to build image with ROS.