Analogue Camera Adapter V2.0A and CameraDemo

Hello I’m using the Analogue Camera Module V2.0A with the Colibri Evaluation Board V3.2 and this
demo and seems to work fine. But I need an example (source) to view a preview of the image of the camera, I downloaded the WindowsCe software libraries and sample for Tegra but the folder CameraDemo is empty. Besides, I have an old wince lib (v1.04.00.1819) that has the source of camera demo, but the solution project couldn´t load a project named CameraPlugin…I think that is a dll project.

So, I wonder if you could tell me where I can download the source code of a camera preview demo.

Extra info: I really need this example because we are testing solutions for adding cameras to our product and I think that this is the way to go.

Thanks in advanced!

We have improved our camerademo application with quite some good features. Currently, it is in the testing phase, it will take a couple of days to release. Let you know the update once we release the application.
Please let me know if you are looking for this immediately.

A couple of day it’s ok for me, please let me know when the demo is ready.

Do you have any news of the release for CameraDemo? thx

We have improved camera demo project of tegra. Please download source code from here.
This project will be able to build of using Windows CE Software Libraries

Thanks! I’ll test it and talk back to you with results.

Hi @raja.sivasankaran, unfortunately I could not build the code, I tried changing different things but it was impossible.

I also had to add libraries to the linker and several .h files (gpiolib, i2c, coproc, etc).

Do you have full version that builds for SDK2wince7 (ARMV4I)?

Please download the source code (not building) from here

The visual studio properties files not updated to latest. Please download it from here and overwrite on the Windows CE Software Libraries and then try to build the application.
Please use our latest SDK from here.

ok, seems to work for me. Is there any chance to make it work with the 1.4 release image?

Thanks a lot!

I’m picking up on this topic, and I still have some problems.
I’m using:

  • WEC7 image version 2.1
  • Toradex Evaluation Board 3.2A
  • ACA V2.0A
  • This software CameraDemo

With this configuration I can´t see any image from camera on any channel of the ACA. Could you confirmed me if I need to set up anything else or special?

Besides, do you have any source code demo?

Dear @skabo,

I made the same software and hardware setup and camera is working for me. Could you please check JP2 jumper selection, it must be open for default executable application. We are published our camera demo source code here. Default channel D1 is selected, if there are no camera source input and test pattern should be seen on the display.

Still, if it is not working then share below things

  1. Snapshot(picture) of your hardware setup.
  2. Log debug message and send to us

Ok, I made the test with and without the JP2 jumper and achieved the same result.

if there are no camera source input and test pattern should be seen on the display.

Never saw the test pattern, only black screen.

I attached pictures of my setup and de debug message logs.


Toradex Bootloader 2.1 for Tegra Built Feb 20 2018 09:03:40

Press [SPACE] to enter Bootloader Menu

Colibri T20 512MB V1.2A  SerialNo: 4754260
RAM: 512 MB, CarveOut: 64 MB
Locating kernel image in flash...Done(1361)
Decompressing IMAGE(25957446, 50725972) from FLASH(0) to RAM(16000)...Done(568ms
Jumping to image at 0x80016000...

Toradex Windows CE 7.0 2.1 for Tegra Built Feb 20 2018 09:03:16
INFO:OALLogSetZones: dpCurSettings.ulZoneMask: 0xb
L2 cache enabled
MainMemoryEndAddress adjusted from 0x86000000 to 0x9C000000
Main Phys Mem: 0x00000000:0x1BFFFFFF
Carveout Phys: 0x1C000000:0x1FFFFFFF
Cold boot selected
SMP: Active CPUs = 2
Chip Id: 0x20 (Handheld SOC) Major: 0x1 Minor: 0x3 SKU: 0x8
NVRM Initialized shmoo database
PllClocks(Mhz): X=1000, M=666, C=600, P=216, A=24.576
SysClocks(Mhz): CPU=1000, AVP=240, SysBus=240, Mem=333, EMem=666
GraphicClocks(Mhz): Host=108, 3D=111, 2D=111, Epp=111, Mpe=111, Vde=240
Loading FlashFileSystem(NAND)...
Micron M71M PS:4KB BS:256KB DS:1024MB BCH16 ECC
INFO: TotalBlocks = 4096, FreeBlocks = 178
BBs: 1
No TAT bad block found.
No TT bad block found.
Done FlashFileSystem(NAND)(115)
Loading Audio...Done
Loading Serial2(UART_B)...Done Serial2(0)
Loading Serial3(UART_C)...Done Serial3(0)
Loading SDIO(SDIO4)...Done(1003)
Loading USBFunction(Port1)...Done
Loading USBHost(Port2)...Done
Loading USBHost(Port3)...Done
Loading DisplayDriver...Done(36)
Set LCD to 640x480 (60Hz)
Loading Keyboard/MouseDriver...Done
Loading TouchDriver...Maximum Allowed Error 5:
No external RTC found
AX88772B: instantiate [AX88772B1]
Loading NETUI...
	0x0003A53C Video Renderer Filter
		0x0003A9FC [In ]	V
ideo Renderer Input		Connected to:0x00037BFC
	0x00036FFC Video File Wr
		0x007F000C [In ]	VideoIn		Connected to:0x0003AD0C
x0084000C [In ]	AudioIn		Not Connected
	0x00036A0C Still Image File Writ
		0x0075000C [In ]	VideoIn		Connected to:0x0003BEEC
x007A000C [In ]	AudioIn		Not Connected
	0x0003967C H264 Video Encoder Fi
		0x0003AC0C [In ]	XForm In		Connected to:0x0
		0x0003AD0C [Out]	XForm Out		Connected to:0x0
	0x00038A9C Still Image Encoder Filter
		0x0003AE0C [In ]	X
Form In		Connected to:0x0003831C
		0x0003BEEC [Out]	XForm Ou
t		Connected to:0x0075000C
	0x000377AC Video Capture Filter
x00037BFC [Out]	Preview		Connected to:0x0003A9FC
		0x00037F8C [Out]	C
apture		Connected to:0x0003AC0C
		0x0003831C [Out]	Still		C
onnected to:0x0003AE0C
Loading AVP library nvrm_avp.axf
Loading AVP library nvmm_manager.axf
AVP: Legacy AVP kernel (Mar 21 2014 20:02:45)
Loading AVP library
Loading AVP library nvmm_jpegenc.axf
Clock set [CORE] 125000 [External for Pads] [Internal Clock for Core] Result: 12
1090 KHz
Clock set [SENSOR] 27000 [External for Pads] [SubConfig] Result: 27000 K
Clock set [CORE] 81000 [External for Pads] [Internal Clock for Core] Result: 8
3250 KHz
Clock set [SENSOR] 27000 [External for Pads] [SubConfig] Result: 27000 K
Clock set [CORE] 81000 [External for Pads] [Internal Clock for Core] Result: 8
3250 KHz
Clock set [SENSOR] 27000 [External for Pads] [SubConfig] Result: 27000 K
Clock set [SENSOR] 27000 [External for Pads] [SubConfig] Result: 27000 KHz
ived message: BlockError
Received message: BlockError
GraphEvent: EC_STATE_CHANGE: Paused
GraphEvent: EC_STATE_CHANGE: Running
GraphEvent: EC_ERRORABORT: HRESULT=80004005
GraphEvent: EC_ERRORABORT: HRESULT=80004005
GraphEvent: EC_ERRORABORT: HRESULT=80004005

Dear @skabo,

Thank you for the details. I guess there could be a connection problem between the camera adapter to Colibri Eval board. Could you please check the cable continuity.
I made similar setup and able to see camera preview. Attached reference pictures and logs here.

Let us know still if you need any help on this.

ok, I just realized that some jumpers for I2C had been removed from evalutaion board, it’s working now. Thanks a lot.

I’ve one more question, how can I switch the analog input of the module? I’m trying to find this looking at the code example here without success. Thanks in advanced.

Dear @skabo
I moved this question into a new post:

Regards, Andy