Adding Wayland to angstrom-qt5-x11-image

Hi all!

I am new to Yocto and Toradex and I am trying to build Wayland on apalis and I am using one of your pre-built supported image to add this window manager alongside x11. I have tried to follow the suggested instructions on the following links.

However, I can’t seem to make any of these work on angstrom-qt5-x11-image.

I am using the repo LinuxImageV2.8.

The changes I had on the build/local.conf file are the following.

  1. Uncomment the DISTRO_FEATURES_remove = “wayland”
  2. MACHINE ?= “apalis-imx6”
  3. Add the following lines at the end:


ACCEPT_FSL_EULA = "1"        
DISTRO_FEATURES_append = " wayland"
DISTRO_FEATURES_remove = " x11"
IMAGE_INSTALL_remove = "eglinfo-x11"
IMAGE_INSTALL_append = " qtbase qtbase-plugins qtwayland cinematicexperience liberation-fonts"
IMAGE_INSTALL_append = " qtquickcontrols qtquickcontrols2 qtdeclarative qtserialport pulseaudio pulseaudio-server pulseaudio-misc pulseaudio-module-dbus-protocol"

The errors I am getting are as follows:

ERROR: qtwayland-5.9.4+gitAUTOINC+83db09bd0a-r0 do_configure: Error calling /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-mx6qdl-angstrom-linux-gnueabi/qtwayland/5.9.4+gitAUTOINC+83db09bd0a-r0/recipe-sysroot-native/usr/bin/qt5/qmake -makefile -o Makefile       /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-mx6qdl-angstrom-linux-gnueabi/qtwayland/5.9.4+gitAUTOINC+83db09bd0a-r0/git/  --   -no-feature-drm-egl-server -no-feature-libhybris-egl-server -no-feature-wayland-brcm -feature-wayland-client -feature-wayland-egl -feature-wayland-server -feature-xcomposite-egl -feature-xcomposite-glx
ERROR: qtwayland-5.9.4+gitAUTOINC+83db09bd0a-r0 do_configure: Function failed: do_configure (log file is located at /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-mx6qdl-angstrom-linux-gnueabi/qtwayland/5.9.4+gitAUTOINC+83db09bd0a-r0/temp/log.do_configure.29228)
ERROR: Logfile of failure stored in: /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-mx6qdl-angstrom-linux-gnueabi/qtwayland/5.9.4+gitAUTOINC+83db09bd0a-r0/temp/log.do_configure.29228
NOTE: recipe qtwayland-5.9.4+gitAUTOINC+83db09bd0a-r0: task do_configure: Failed
ERROR: Task (/home/lai/oe-core/build/../layers/meta-qt5/recipes-qt/qt5/ failed with exit code '1'

ERROR: qt3d-5.9.4+gitAUTOINC+02d01a6897-r0 do_compile: oe_runmake failed
ERROR: qt3d-5.9.4+gitAUTOINC+02d01a6897-r0 do_compile: Function failed: do_compile (log file is located at /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/qt3d/5.9.4+gitAUTOINC+02d01a6897-r0/temp/log.do_compile.41144)
ERROR: Logfile of failure stored in: /home/lai/oe-core/build/tmp-glibc/work/armv7at2hf-neon-angstrom-linux-gnueabi/qt3d/5.9.4+gitAUTOINC+02d01a6897-r0/temp/log.do_compile.41144
NOTE: recipe qt3d-5.9.4+gitAUTOINC+02d01a6897-r0: task do_compile: Failed
ERROR: Task (/home/lai/oe-core/build/../layers/meta-qt5/recipes-qt/qt5/ failed with exit code '1'

Any input / suggestions are appreciated.


hi @jkonwat: Did you update the meta-qt5 recipes to Qt 5.10.0 and apply the patches as written by charesyc?

Hi Jaski,

Yes, I did switch to branch 5.10 for the meta-qt5 recipes.


Thanks for the Information. Which image did you build? Console Image?

Hi jaski.tx.

I have tried on angstrom-qt5-x11-image and console-tdx-image. The one I posted is from angstrom-qt5-x11-image. I would like to build it on angstrom-qt5-x11-image, but if it is simpler on the console-tdx-image, then I am open to that as well. I would really appreciate your help. I have been stuck on this for 2 weeks now.


@jkonwat: We are currently looking into this issue and will come back soon to you.

Thanks! Appreciate it.

@jaski.tx Hi! Any news about this issue?

@jkonwat, we are still working on this issue. By the way, what is your application? Why do you need wayland?

Hi @jaski.tx ,

Thank you for the response. We are working on a quick boot up for a Qt application using the Apalis Imx6 EVK. We are currently at 12.5s boot up time using x11. We noticed that the x11 takes a bit of time to start. We need a windows manager as we will be running 2 mutually exclusive applications.


Hi @jkonwat

Can you maybe share the full bitbake log as well as the log file log.do_configure of qtwayland? Did you clean your whole tmp directory as well as sstate? Also please note that our X11 image has quite some dependencies to other X11 applications. I think you would better use another image like core-image-weston…



Thanks for the suggestion and responses. We just ended up using the Boot2Qt recipe instead.