Adding mono layer error

I am using Colibri iMX6DL 512MB V1.1A with Colibri evaluation board V3.2 and i am using toradex provided embedded linux angstrom lxde v2.8b.
I tried to add mono layer into my image using yocto project and i followed this link and it ran into errors and i have attached the screenshot of those errors.


1.Is it necessary to add meta-mono layer into my image to start using mono develop and i tried without adding meta-mono but i got errors regarding gtk-sharp missing.
2.Can you share the step by step procedure to a layer mono layer into linux image for colibri iMX6

Hi

Please note that copy/past text is preferable over screenshoots. It makes our lives way easier.

There was a missing " in your conf/bblayers.conf file. Looks like you corrected that in a later stage.

The error message bitbake gives tells you that the branch you checked out of meta-mono is not compatible with rocko. It is meant for a ‘sumo’ or ‘thud’ based installation.

As meta-mono has no rocko branch you could try one of two approaches:

a)

Check out the ‘pyro’ branch of meta-rocko and try to build.

b)

Modify the meta-mono/conf/layer.conf file. Add rocko to the list of compatible layers.

LAYERSERIES_COMPAT_mono = "rocko sumo thud"

Max

thank you,it worked