Able to capture RAW image with gst-launch and not with v4l2-ctl

I’m facing issue with capturing raw image with v4l2-ctl. Let me explain the issue. I’m observing this issue only in 6.2.0 torizon version and not in 5.7.0

Im trying to take a raw image for 2592 X 1944 resolution with v4l2-ctl and I can observed the size of image is equal that of 1080p image, and if I view it im not getting the complete image.
whereas if I try to capture raw with gst-launch , Iam able to do it without any issue.

I am able to observe that the resolution set by gstreamer is overriding the v4l2 resolution
please refer below image
As first step im switching resolution using gstreamer . then as next step im saving the image using v4l2 of different resolution.
the 3rd column is the image size i’m getting and 4th column is the actual image size that I should be getting.

Gstream Image

V4l2 Image

Greetings @sapthagiri,

Are you running v4l2 and gstreamer inside a container?

Could you provide the exact commands you are running here and I can try to see if I can reproduce this with a simple USB camera.

Also just to clarify, you said this only happens on TorizonCore 6, yes? So on TorizonCore 5 the configured resolutions for v4l2 and gstreamer stay separate and don’t interfere with each other correct?

Best Regards,



gst-launch-1.0 v4l2src device=/dev/video2 num-buffers=1 ! “video/x-raw,width=1920,height=1080” ! jpegenc ! filesink location=gstreamer.jpg

v4l2-ctl --device /dev/video2 --set-fmt-video=width=2592,height=1944,pixelformat=UYVY --stream-mmap --stream-to=frame.raw --stream-count=1
I tried testing it with USB camera. There is no issue with USB CAM.

yes the gstreamer and v4l2 don’t interfere with each other

Hi @sapthagiri,

So I assume the camera is connected through CSI?

Can you give some details (or a link) to the camera you are using?

Best Regards

Just to confirm your findings, I too didn’t notice any issues with my USB camera as well. I guess somehow the issue is specific to your camera, or maybe CSI cameras in general. Though I don’t have a CSI type camera around to confirm. As Kevin said we may need more information about the specific camera you are using.

Best Regards,

Hi @kevin.tx ,
Just happened to find the root cause of the issue and resolved it.

1 Like


Err:6 buster Release

  • Certificate verification failed: The certificate is NOT trusted. The certifica te chain uses expired certificate. Could not handshake: Error in the certificat e verification. [IP: 443]*
    Get:7 Index of /debian buster/main arm64 Packages [7737 kB]
    Get:8 Index of /debian buster-updates/main arm64 Packages [8780 B]
    Reading package lists…
    E: The repository ‘ buster Release’ does not have a Release file.

Im facing issue while docker build. This is due to issue in certificate verification. Do you have any idea to bypass this certificate verification. tried few methods but failed to do so.

1 Like

What is your Dockerfile here used for this build? It looks like you’re fetching things for Debian Buster. But our supported Debian containers are for Debian Bullseye and Bookworm only. That’s probably why it fails trying trying to access our feeds for Debian Buster.

Best Regards,