A start job is running for run pending postinsts


My newly build kernel hangs with the message.

[***] a start job is running for run pending postinsts

How can i solve such a problem?

Best regards

Note this last message you are seeing is not really a kernel message so whether or not the kernel is hanging would first have to be proven.

Is that now with our official BSP or some custom built intermediate stuff? I’m just asking as we fixed a couple of such issues in the final V2.7 beta 1 which you may not have picked up yet.

If you are using one of them early V1.0 hardware samples I assume you do understand all the erratas and their implications.

Did you actually just try to reset and does it hang there again?

Hi. Restart doesn’t help to overcome this problem. I compiled the same sources with BSP2.6.1 this morning and the image worked. I am using the official Toradex BSP 2.7 (checked out today) and use the same hardware setup which is an Apalis TK1 on Ixora.

This is the complete boot log.

This U-Boot message does not sound familiar:

Resetting to default environment

Saving Environment to MMC…
Writing to MMC(0)… done

Looks like something went wrong there. This leads to the igb_mac not being set later when booting the Linux kernel:

[ 0.000000] Kernel command line: lp0_vec=2064@0xf46ff000 core_edp_mv=1150 core_edp_ma=4000 usb_port_owner_info=2 lane_owner_info=6 emc_max_dvfs=0 ip=off root=/dev/mmcblk0p2 rw rootfstype=ext3 rootwait igb_mac= consoleblank=0 no_conso1

And then the rest after no_conso1 is just cut.

Above mentioned igb_mac being missing leads to the following:

[ 3.151254] igb 0000:03:00.0: using Toradex OUI as default igb MAC

[ 3.206757] igb 0000:03:00.0 eth0: MAC: 00:14:2d:00:00:00

Could it be that you have some mini-PCIe device connected which you missed mentioning? May we know what else you may have connected?

[ TIME ] Timed out waiting for device sys-subsystem-net-devices-wlp1s0.device.
[DEPEND] Dependency failed for set wifi antenna to aux.

Ah, probably some Wi-Fi device, right? Have you tried without that one at all?

As mentioned before and unfortunately ignored by you we do recommend first trying with our official BSP demo image. Just to make sure your baseline is proper. Then you may try your custom build which we recommend not further customising at first to check that baseline and then starting with your modifications step by step. The same applies to adding various add on devices be it mini-PCIe, USB or whatever else you may desire to add. And actually mentioning the whole hardware setup including all other connected pieces may help us helping you.

BTW: You may want to check whether some of our recent patches on our -next branch may be applicable for you as well.

Yes, there is indeed a PCIe wifi card based on a Qualcomm Atheros QCA6174 chip. And yes, i am aware that it does not work at the moment because of hardware bugs (but it works with my mx6/ixora). The only other hardware i need is an USB device.
I just compiled and checked the "vanilla’ build of BSP2.7 and it works like expected. No hangups, no problems.