10Mbit Ethernet on Colibri VFxx under WinCE 6.0

Hi all.

In new BSP version V1.3beta4 (Release date: 2016-04-14) is adding support for 10Mbit Ethernet (issue 14134).
But it seems to me, it doesn’t work.

I try to add lines:


;to change settings uncomment this, if uncommneted auto connect is off

"SpeedMode"=dword:0 ;1 -> 100mbit, 0 -> 10mbit

"DuplexMode"=dword:0 ;1 -> full, 0 -> falf'

in to ToradexFiles.reg file.

After OS image building my application doesn’t work and I can’t even ping my Colibri device. I try use Ethernet-switch - nothing changed. I try use crossover and patch (strait) cable - nothing changed.

When I remove these lines from ToradexFiles.reg file — all works fine, I can ping Colibri. But I can run my application only with Ethernet-switch, via color of LED on Ethernet-switch I see, that speed of Colibri is 100Mbit.

Is your network 100mbit or 10mbit? When you set speed it also disables auto-negotiation. It may have issues working on 100mbit network than.

I do not have the network as such.

I have Colibri VF50 and laser scanner Sick, and I should to connect them.
Laser scanner Sick works ONLY on 10Mbit and halfduplex mode.

I tried to use Ethernet-switch to connect together Colibri (100Mbit Ethernet) and laser scanner Sick (10Mbit Ethernet). And I got good working combination, but my task is to escape (avoid) of the Ethernet-switch.

I tried to ping Colibri from connected PC via the Ethernet-switch.

When you set 10mbit it also disables auto negotiation. It will not be able to connect to 100mbit network with that.

Earlier I used eBox3300 mini PC and I not had any problems with direct connection with Sick laser scaner over 10 Mbit Ethernet.

Now I ported my application to Colibri VFxx - it works better. I hope some problems (for example, 10 Mbit Ethernet connection) will disappear in near future.

We will look into this and I will let you know what could be the issue. It will take some time to start looking into this. I will give you update after 2 weeks

Is there any update on this issue? I believe I have a similar problem. My network including Netgear Prosafe switch works perfectly if I set 100Mbit/sec but won’t work at 10Mbit.

We have a new driver available. Please let me know what version of OS do you have and I will upload you driver here.