Yocto problem building Apalis iMX8QM image

Hello Everyone,
The HW and SW are as follows:

Apalis 4GB iMX8QM WB IT V1.1 C
IXORA V1.2A
Host OS: Ubuntu 20.04 LTS

I am trying to build a Reference Image with Yocto Project given at the below link:

I have
Manifest merge branch: refs/heads/dunfell-5.x.y
Manifest groups: all,-notdefault

and

user@Optis:~/dev/.repo/manifests$ git branch -a

  • default
    remotes/m/dunfell-5.x.y → origin/dunfell-5.x.y
    remotes/origin/dunfell-5.x.y
    remotes/origin/master

I am able to build a Reference Image for apalis-imx8
MACHINE ?= “apalis-imx8”
DISTRO ?= “tdx-xwayland”

However, I get the following error when I try to build an image (DISTRO ?= “tdx-xwayland”) for the machine mentioned at the start of the post i.e. MACHINE ?= “apalis-imx8x”


~/dev/build$ bitbake tdx-reference-minimal-image
ERROR: OE-core’s config sanity checker detected a potential misconfiguration.
Either fix the cause of this error or at your own risk disable the checker (see sanity.conf).
Following is the list of potential problems / advisories:

MACHINE=apalis-imx8x is invalid. Please set a valid MACHINE in your local.conf, environment or other configuration file.

It is given at below link that Machine name should be ‘apalis-imx8x’ in local.conf for Toradex Module ‘Apalis iMX8X V1.1B and newer’

Could you tell me what step I am missing?

Best Regards,
Salman

Hi Salman,

The iMX8QM WB IT V1.1c is an iMX8. It is not a iMX8X. see this link and note it lists the imx8 product line and your machine is listed: Apalis iMX8 | Toradex Developer Center

It seems to be working correctly for you based on your results. Go with the MACHINE ?=“apalis-imx8” that is the correct one for your machine.

Hope this helps.

Hi @Salman ,

That’s right what @shazen has mentioned. Please set the MACHINE variable to “apalis-imx8” and you should be fine.

Have a nice day and a successful week.

Best Regards
Kevin

Dear @kevin.tx and @shazen thank you very much for the information.