Yocto (Dunfell): Very slow Bitbake compilation / build

Hi team,

I’m compiling the latest monthly devel and I’m surprised how slow it is going. Compared to BSP 2 or 3, it is several times the compilation.

We know Yocto is slow but… Qt is taking more than one hour (and stuck in a do_package) with the CPU load close to cero.

Please check this screenshot:

My commands where:

repo init -b refs/tags/5.1.0-devel-202012 -m tdxref/default.xml
repo sync

(Chose my MACHINE in local.conf)

. export
bitbake tdx-reference-multimedia-image	

I’ve tried the following in local.conf but it doesn’t improve the situation.


Is this normal? Thanks

It seems that the Qt related packages take a lot of time. So unless you really want to use Graphical interface, try to use the tdx-reference-minimal-image or remove all the Qt packages from the image recipe (More info: Build a Reference Image with Yocto Project/OpenEmbedded | Toradex Developer Center)

Also, I found that leaving the default config worked better than trying to add my own changes so I removed my added changes:


and let Bitbake do its thing.