Yocto distro not using TCP windows scale option


I use the Toradex Yocto distribution with a Verdin IMX8-MM and it seems that TCP Windows scaling option is not send in SYN packet even if it’s enabled.

I have configured : net.ipv4.tcp_window_scaling = 1

And my socket receive buffer size is greater than 65 K :

>>> import socket
>>> server = socket.socket(socket.AF_INET, socket.SOCK_STREAM)
>>> print(server.getsockopt(socket.SOL_SOCKET,socket.SO_RCVBUF))

Even with standard command like wget, I never see the TCP windows scale option.
On my laptop if I use wget, I can see in Wireshark that TCP windows scale is announced.

Is there more parameters to activate in yocto ?

Thanks for you help.

Hello @neunz ,

Could you please share the output of uname -a?
And could you also tell us what was your expected behaviour with this?

Best regrdas,

Here the result :

uname -a
Linux verdin-imx8mm 5.4.77-5.1.0-devel+git.8fc7bd5da76f #1 SMP PREEMPT Mon Nov 30 08:44:04 UTC 2020 aarch64 aarch64 aarch64 GNU/Linux

I expect that my TCP socket receive buffer go up to my desired size.
Without TCP windows scale option it get full at 65K.

Hi @neunz ,

if you follow the link Embedded Linux Release Matrix you can see our current release is BSP 5.5.0.

I recommend giving this newer version a try, it might fix your issue.

You can find the versions here Toradex Download Links (Torizon, Linux BSP, WinCE and Partner Demos) .

Let us know if the issue persists.

Best Regards