WinCE UpdateLib: Ce Libs 2.1 required to update an OS based on BSP 1.3b4?


we’re updating our application by flashing a new OS using the update lib.
I’m getting an error in Upd_Restore when using CE libs 2.0 to update to an OS image based on BSP 1.3b4.
I can update the same OS image when using CE libs 2.1 without problems.

Do i need to use CE libs 2.1 when updating an OS image based on BSP 1.3b4?

Yes. Compressed image format has been changed in 1.3b4 to make image loading faster. Libraries and update tool are backward compatible with the old format, but you need the latest release of both to be able to flash the new image. You also need to update your bootloader, otherwise you’ll get an error when trying to load the image from flash.
No changes are required if you use uncompressed (.bin) images.