Wifi connection problems

Dear Community;

We are developing some autonomous stations that get same images and send them to ours computers. We have two T30 and two cameras conected to the rj45 pin of the iris. So we need a usb wifi dongle (we are using LM 006) to transmit the images. The T30 are connected to wifi that is created with a 4G router.

The problem is that sometimes we lose the wifi connnection. Sometimes when rebooting the T30 there is no wifi connection. We enter to connnmanctl we scan for wifi and when can see about 5 different networks, but no ours. The wifi connection went fine about for five days, but know, without changing anything in the T30 or router configuration sometimes we can not connect.

I have to say that we are using linux 2.6 beta 3, I think, and with a custom kernel with deployed kernel modules.

The wifi dongle works fine in WINCE 7, and we dont have any idea why sometimes work good on linux and why other time we can even detect the network.

Any help or suggestion is appreciated. Thanks a lot.

Ander.

If you can see other networks and it stopped working suddenly, I would suspect that something bad happened to the ap hw. However, we’ve improved LM006 support in 2.7 BSP release. You should try building your image using 2.7 rather then old beta release, and trying again.

Thanks, for your answer Dominik. We have tried with 2.7 BSP but we have same results more or less. As the LM 006 is out of stock we also have the LM 816 modules. However they are not recognised, I thought that as we deployed and installed the kernel modules with our “custom” kernel they should work. I have repeated the process and when installing kernel modules I can see this:

sudo -E make INSTALL_MOD_PATH=/home/ander/Documentos/Iris/Colibri_T30_LinuxImageV2.7/rootfs/ modules_install

INSTALL drivers/hid/hid-multitouch.ko

INSTALL drivers/input/touchscreen/fusion_F0710A.ko

INSTALL drivers/net/wireless/rt2x00/rt2800lib.ko

INSTALL drivers/net/wireless/rt2x00/rt2800usb.ko

INSTALL drivers/net/wireless/rt2x00/rt2x00lib.ko

INSTALL drivers/net/wireless/rt2x00/rt2x00usb.ko

INSTALL drivers/net/wireless/rtlwifi/rtl8192c/rtl8192c-common.ko

INSTALL drivers/net/wireless/rtlwifi/rtl8192cu/rtl8192cu.ko

INSTALL drivers/net/wireless/rtlwifi/rtlwifi.ko

INSTALL drivers/net/wireless/zd1201.ko

INSTALL drivers/scsi/scsi_wait_scan.ko

INSTALL drivers/usb/class/cdc-acm.ko

INSTALL drivers/usb/class/cdc-wdm.ko

INSTALL drivers/usb/serial/option.ko

INSTALL drivers/usb/serial/usb_wwan.ko

DEPMOD 3.1.10-gbe10973-dirty

Warning: you may need to install module-init-tools

See http://www.codemonkey.org.uk/docs/post-halloween-2.6.txt

The RTL8192cu is the chipset of the LM 006, so I think is working for that reason.

My question is, how can I do the same but for RTL8188eu chipset?

Thanks again.

Hello Dominik,

If i make make menuconfig I can see in drivers wirelless that the rlt8192cu is selected as modular. I have been searching an I am unable to find a driver for rlt8188eu. Where can I find this driver?

Thanks.

We provide wifi drivers as a backports package. When building image using openembedded (according to instruction here) they will be compiled and included in the image.

Thanks for the answer. I still want to know if there is any option to install the drivers of the LM 816 module without openembedded building.

You’ll need to compile backports after kernel compilation.
First follow the kernel compilation instructions, then clone backports in a separate directory and checkout toradex-4.11 branch ( http://git.toradex.com/cgit/backports-toradex.git/log/?h=toradex-4.11)

run:
make KLIB=<kernel_sources_dir> KLIB_BUILD=<kernel_build_dir> INSTALL_MOD_PATH=<modules_install_dir> INSTALL_MOD_DIR=<modules_install_dir> menuconfig

select required drivers and run
make KLIB=<kernel_sources_dir> KLIB_BUILD=<kernel_build_dir> INSTALL_MOD_PATH=<modules_install_dir> INSTALL_MOD_DIR=<modules_install_dir> modules
make KLIB=<kernel_sources_dir> KLIB_BUILD=<kernel_build_dir> INSTALL_MOD_PATH=<modules_install_dir> INSTALL_MOD_DIR=<modules_install_dir> modules_install

Sorry for this late reply. I have been very occupied, but I managed to make the LM 006 work properly. The problem was that the router channel was set to automatic. We realized that when it starts with channel 13 the network was not seen by connmanctl. So this issue is solved.

Regarding to the installation of the LM 816 driver I have some questions, should I open a new topic or comment here?

Thanks for your help.

hi, perfect, that the issue is solved. Please ask a new question.