Which Boot2Qt release matches to BSP2.8?

Does anyone know which release of the Boot2Qt manifests for Yocto corresponds with the BSP2.8 version of the Toradex kernel?

Deficiencies with the BSP5 kernel + iMX M4 interaction are forcing me to fall back to 4.9 to see if I can get something to work. Qt doesn’t track Toradex releases so I’m hoping Toradex did. Thanks.

Hi @lkoziarz,

There’s not necessarily a “correspondence” as Boot2Qt is built with a BSP totally handled by Qt itself.

If you need to stay with an LTS release, I would recommend you to stay with our BSP 3.0.4.

About Boot2Qt, one of their latest releases was 5.15.2. It’s not working fine for you?

Best regards,
André Curvello

The Qt/Yocto manifests (https://code.qt.io/cgit/yocto/boot2qt-manifest.git/tree/) pick up various commits in the meta-toradex-nxp repository, so there’s a correspondence in there somewhere.

Qt 5.15.x is working just fine, I need a kernel that can support FreeRTOS on the M4 running simultaneously with Linux. There are other threads here covering that issue, @gustavo.tx can point you to them.

Hi @lkoziarz,

I’m checking that internally to be sure.

As soon as I have a position about it, I’ll provide you feedback here.

Best regards,
André Curvello