Weston not working on VGA display

What should the output name in weston.ini be for VGA display on colibri evaluation board with drm-backend? /sys/class/drm has only card0 and card0-DPI-1, so I have tried with name=DPI-1. The display shows terminal output normally.

modetest -M imx-drm fails with “failed to open device ‘imx-drm’: No such file or directory”

journalctl doesn’t help much either:

colibri-imx8x systemd[1]: Starting Weston Wayland Compositor (on tty7)...
colibri-imx8x systemd[1]: Started Weston Wayland Compositor (on tty7).
colibri-imx8x systemd[1]: weston.service: Main process exited, code=exited, status=1/FAILURE
colibri-imx8x systemd[1]: weston.service: Failed with result 'exit-code'.


[09:21:48.044] weston 5.0.0
               Bug reports to: https://gitlab.freedesktop.org/wayland/weston/issues/
               Build: 5.0.0-33-gfb563901-dirty MGS-4627 [#ccc] weston will turn off when panel-psotion=none and use gplay (2019-03-14 11:30:30 +0800)
[09:21:48.045] Command line: /usr/bin/weston --log=/var/log/weston.log
[09:21:48.045] OS: Linux, 4.14.117-3.0.2+ge43e3a26e1b7, #1 SMP PREEMPT Tue Nov 12 08:50:01 UTC 2019, aarch64
[09:21:48.046] Using config file '/etc/xdg/weston/weston.ini'
[09:21:48.049] Output repaint window is 16 ms maximum.
[09:21:48.050] Loading module '/usr/lib/libweston-5/drm-backend.so'
[09:21:48.058] initializing drm backend
[09:21:48.066] logind: session control granted
[09:21:48.071] using /dev/dri/card0
[09:21:48.071] DRM: supports universal planes
[09:21:48.071] DRM: supports atomic modesetting
[09:21:48.071] DRM: does not support picture aspect ratio
[09:21:48.072] Loading module '/usr/lib/libweston-5/gl-renderer.so'
[09:21:48.102] EGL client extensions: EGL_EXT_client_extensions
               EGL_EXT_platform_base EGL_KHR_platform_wayland
               EGL_EXT_platform_wayland EGL_KHR_platform_gbm

Please let me know if I can provide any other information to help debug this!

Hi @stuo

Thanks for the writing to the Toradex Community?

Could you provide the version of the software ( uname -a and cat /etc/issue ) of your module?

Thanks and best regards,

I run into the same issue, console output OK, but blank screen with weston.

cat /etc/issue:

TDX Wayland with XWayland 2.6-snapshot \n \l

Colibri-iMX8X_Console-Image 3.0b2.65 20190830

and (uname -a):

Linux colibri-imx8x 4.14.117-3.0.2+ge43e3a26e1b7 #1 SMP PREEMPT Tue Aug 27 01:06:55 UTC 2019 aarch64 GNU/Linux

Colibri iMX8QXP 2GB V1.0B
Colibri iMX8DX 1GB V1.0B
Colibri Evaluation Board Rev. 3.2
Linux Console Image

hi @stuo, hi @dst

Could you install the newest nightly build? We tried it on our side and this was working.

Best regards,

Hi, thanks for answers!

I found elsewhere that this might be related to toradex easy installer, and in uboot I set env default -a and saveenv and next boot weston launched normally.

Still modetest fails with imx-drm, though. Same thing with nightly build.

uname -a

Linux colibri-imx8x 4.14.117-3.0.2+ge43e3a26e1b7 #1 SMP PREEMPT Tue Nov 12 08:50:01 UTC 2019 aarch64 GNU/Linux

/etc/issue (this is from custom build, but I tried nightly and release ones from easy installer)

TDX Wayland with XWayland 2.6-snapshot \n \l

Colibri-iMX8X_Console-Image 3.0b2 20191118

It’s just that instead of imx-drm it uses mxsfb-drm which is handling the eLCDIF giving you parallel RGB. And if e.g. using modetest one has to explicitly specify this using -M mxsfb-drm.

can confirm, after setting back the u-boot env (after a fresh install with easyinstall) weston starts and gets displayed as it should! Thank you for the hint.

But maybe someone knows which env settings is causing the issue?

Best regards

That explains! Thank you. No more questions at the moment :slight_smile:

Hi @dst

Perfect that you found a solution.
The issue is in Toradaex Easy Installer which should be solved in the next release.

Best regards,

Is modetest utility on purpose not included in the console image? It is in LXQt image

Yes, it has to do with fdt_high which needs removing: