WEC7 1.4b BitBlt slow

I have now updated to 1.4b2. Unfortunatey I could not see that 2D acceleration is working now. In the link I send you a short test program. For imx6-Apalis I still get values ob about 80 ms for the BitBLT/TransparentBLT/BitBlt sequence. I would expect values below 10ms.

Even worse: When the display works in full hd resolution I get strange pictures - maybe there is not enough memory. In SVGA resolution it is ok.

With BSP 1.3 the display was ok even in full hd.

Where is your comment ?

ok, I was only a little bit confused because I saw “commented” but there was no comment.

Just another remark: My display is set to 1920X1080 (FullHD).
In my bltTest you see the 2 defines

define SCREENX 1920
define SCREENY 732

The above values are the maximum values which work.
If I define SCREENY 733 the return value of BitBlt and TranparentBlt gets 0

Dear @Frax222
We will get back to you about this question next week. Thank you for your patience.
Regards, Andy

  1. For issues at full-hd resolution, this is probably due to the amount of memory allocated for the image processing unit. The size depends on the RAM available on the module, but you can change it using config block parameters. You can use serial terminal and press space to stop normal boot process and then press “x” to access the console.
    You can type:
    set memcfg.ipumem
    to increase the amount of memory used.
    As an alternative you can reduce the BPP of your screen using registry settings:
    https://developer.toradex.com/knowledge-base/display-driver-registry-settings

  2. I made some changes to our display driver to improve performances and now I get less than 10ms timing with your test application.
    Here https://share.toradex.com/x936vkv3rd9r1yw you can find an updated driver, it’s not fully tested but if you can also test it with your typical usage scenario we will appreciate your feedback.
    If you build your own OS image you can just overwrite the file inside the binary BSP folder. If you use our standard image you can copy the file to \FlashDisk\System, rename it to ipuv3flat_1.dll and change the entry under:

    [HKEY_LOCAL_MACHINE\System\GDI\Drivers]
         "Display"="ipuv3flat.dll"
    

to

[HKEY_LOCAL_MACHINE\System\GDI\Drivers]
    "Display"="ipuv3flat_1.dll"

This fix should be part of our next 1.4b4 release.

Hello Valter,

  1. BPP is set to 16. I tried reducing to 8, but then system crahses during boot. I also had no luck with set memcfg.ipumem (see screenshot)alt text
  1. I also get less than 10ms with my test application. But when I increase the defines SCREENX and SCREENY then the system crashes. It still works with 1920720, but it crashes with 1920730.
    It should work with 1920*1080 of course.

Kind regards

8 BPP is not supported on imx6.
Sorry, I made a mistake, it’s:
mem.ipumem

it says 0.

I can enter a value (which would you recommend for FullHD, BPP 16) ?

But after booting it is 0 again.

Can you try to increase it to 32MB, if you want you can also decrease gpumem.
After you change the values you have to type:
save mem
to make the change permanent.

I am trying to investigate the issue about resolution.
To reproduce that I have to:

  • set screen resolution to 1980x1020
  • change SCREENX and SCREENY defines in the code
    Is that correct? Or you only increased the values inside the code, leaving screen res to default?

Hello Valter,

I have screen resolution FullHD (19201080 connected via HDMI). I increase SCREENX and SCREENY from 800600 to finally 1920*1080 (I have to recompile my test application).

But I can tell you that my test application now works with SCREENX/SCREENY set to 1920*1020, the time is about 13ms which is a real good value…

I could not reduce gpumem because it is 0.

I increased ipumem to 33554432 (which is 1024102432).

Increasing simply to 32000000 does not work: system crashes during boot.

Now the test application works and I will go back to my real application.

I will keep you informed when I have tested this. But for the moment thank you very much for your help.

Kind regards

gpumem set to 0 means that the system will use default value (this depends on the total amount of RAM on the module, since on imx6 we range from 256MB to 2GB).
Seems that setting the size to a value that is not a multiple of 4k does not work, sorry for the issue, will document and fix that in next release.
I am happy to hear that your main issue is now solved, will try to fix also the additional ones in next beta.

link text

Hello Valter,

unfortunately ipuv3flat.dll seems to cause problems when a relatively simple html-file should be displayed.

Kind regards

Can you please open a new thread with this issue? It would help in keeping our community content more organized and easier to search.
Does this happen only with the latest update or also in the previous releases (please report this info in the new thread)?

I see that you liked a html file, can you pls provide a bit more information about how to reproduce the issue in the new thread?