VGA display abnormal on Apalis iMX6 with LXQT image

Dear Support Team,

we are testing V2.8b4 LXQT image on Apalis iMX6Q with VGA display connected on Apalis Evaluation Board, it works well when starting up, but when i tried logout, the backlight brightness of VGA display will change to extremely low, just like attached photos, the other functions seems working normally, and the debug console give below meessages, at this time, only rebooting can resolve this problem, could you help check on this? BTW, the stardard LXDE image doesn’t have this issue, it works well.

root@apalis-imx6:~# [   30.623762] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   30.686646] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   30.746729] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   30.888304] pgd = a9264000
[   30.896370] [6dee5290] *pgd=00000000
[   30.905333] CPU: 0 PID: 613 Comm: X Tainted: G           O    4.9.84-2.8.2+gb2a7f2f #1
[   30.918743] Hardware name: Freescale i.MX6 Quad/DualLite (Device Tree)
[   30.930769] task: a918dd80 task.stack: a9164000
[   30.940814] PC is at 0x7679dc00
[   30.949442] LR is at 0x7679ddec
[   30.958060] pc : [<7679dc00>]    lr : [<7679ddec>]    psr: 800f0010
[   30.958060] sp : 7e8eba78  ip : 00007f70  fp : 7e8ebc74
[   30.980500] r10: 00000029  r9 : 00000000  r8 : 00000001
[   30.991105] r7 : 00000008  r6 : 009c6578  r5 : 6dee5280  r4 : 00000000
[   31.002919] r3 : 00003fb8  r2 : 00000000  r1 : 00000008  r0 : 009c6578
[   31.014628] Flags: Nzcv  IRQs on  FIQs on  Mode USER_32  ISA ARM  Segment user
[   31.026978] Control: 10c5387d  Table: 3926404a  DAC: 00000055
[   31.037775] CPU: 0 PID: 613 Comm: X Tainted: G           O    4.9.84-2.8.2+gb2a7f2f #1
[   31.050663] Hardware name: Freescale i.MX6 Quad/DualLite (Device Tree)
[   31.062053] Backtrace: 
[   31.069276] [<8010ba5c>] (dump_backtrace) from [<8010bd34>] (show_stack+0x18/0x1c)
[   31.081676]  r7:00000005 r6:600f0113 r5:00000000 r4:80c1aaf0
[   31.092152] [<8010bd1c>] (show_stack) from [<803f9164>] (dump_stack+0x90/0xa4)
[   31.104205] [<803f90d4>] (dump_stack) from [<80108ad8>] (show_regs+0x14/0x18)
[   31.116168]  r7:00000005 r6:6dee5290 r5:0000000b r4:a918dd80
[   31.126650] [<80108ac4>] (show_regs) from [<8011531c>] (__do_user_fault+0xc4/0xc8)
[   31.138920] [<80115258>] (__do_user_fault) from [<8011552c>] (do_page_fault+0x20c/0x3a4)
[   31.151577]  r8:6dee5290 r7:00000005 r6:a88fd340 r5:a918dd80 r4:a9165fb0
[   31.162881] [<80115320>] (do_page_fault) from [<801157f0>] (do_translation_fault+0x80/0xb8)
[   31.175872]  r10:00000029 r9:00000000 r8:a9165fb0 r7:6dee5290 r6:80115770 r5:00000005
[   31.188350]  r4:00000005
[   31.195520] [<80115770>] (do_translation_fault) from [<8010134c>] (do_DataAbort+0x44/0xc0)
[   31.208554]  r7:6dee5290 r6:80115770 r5:00000005 r4:80c0807c
[   31.218997] [<80101308>] (do_DataAbort) from [<8010cbe0>] (__dabt_usr+0x40/0x60)
[   31.231232] Exception stack(0xa9165fb0 to 0xa9165ff8)
[   31.241130] 5fa0:                                     009c6578 00000008 00000000 00003fb8
[   31.254220] 5fc0: 00000000 6dee5280 009c6578 00000008 00000001 00000000 00000029 7e8ebc74
[   31.267321] 5fe0: 00007f70 7e8eba78 7679ddec 7679dc00 800f0010 ffffffff
[   31.278854]  r8:10c5387d r7:10c5387d r6:ffffffff r5:800f0010 r4:7679dc00
[   31.347650] vgaarb: this pci device is not a vga device
[   31.357041] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   31.417279] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   31.454258] vgaarb: this pci device is not a vga device
[   31.476629] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   31.537026] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz
[   32.278044] mxc_sdc_fb fb@0: 1920x1080 h_sync,r,l: 200,128,328  v_sync,l,u: 5,3,32 pixclock=173010000 Hz

Best Regards

Simon

Hi @hai.tx

I didn’t have the time to test it with a VGA display but I had a similar issue with lxqt when rebooting the device. Now I tested 2.8b5 and the problem seems to be resolved. Can you maybe retest it with 2.8b5 as well?

Regards,
Stefan

Hi Stefan,

Really sorry for late response, i have tested with 2.8b5 release but the issue is still there.