VF61 second ethernet with toradex_vf_4.4

Hello.

I tried to use provided example for second ethernet provided with toradex_vf_4.4 system. I used KSZ8041NL as PHY connected on RMII interface, as adviced on your web-site ( Ethernet/Network (Linux) ). Then I tried to boot device, which stopped after few seconds (here is output from terminal putty.log). What should I change for this to work?

Hello ELT_MZ,

did you also modify your Device tree ?
Also, can you provide the schematic of how you connected the KSZ?

Best Regards

Matthias

Hello Matthias,

i connect the KSZ like this (schematic.pdf).

As for Device tree, I used unmoddified device tree at first.

Then I attempted to make new device tree based both vf-colibri-eval-v3.dtsi and vf-colibri-dusl-eth.dtsi (combination_attempt.patch). With this device tree I successfully booted device, but the second ethernet is still not working, I tried to measure board with oscilloscope and it seems like clock signal is not generating on PTA9.
In my last attemt so far I tried to to swap from fec1 and fec0 to esw device, but with same result (third_attempt.patch).

I used toradex-pinout-designer_1.3.14 to avoid colisions, just to be sure.

In both second and third case first ethernet is working, but the second is not.

In second case during boot there is output, that fec0 didn’t manage to connect to PHY.

I hope those informations will help in solving this problem, I am out of ideas.

With Regards
ELT_MZ

The last wersion shows

[ 0.853421] vf610-pinctrl 40048000.iomuxc: pin VF610_PAD_PTC1 already requested by 40048000.iomuxc; cannot claim for 400e8000.l2-switch

[ 0.865756] vf610-pinctrl 40048000.iomuxc: pin-46 (400e8000.l2-switch) status -22

[ 0.873349] vf610-pinctrl 40048000.iomuxc: could not request pin 46 (VF610_PAD_PTC1) from group fec0grp on device 40048000.iomuxc

[ 0.885197] eth-switch 400e8000.l2-switch: Error applying setting, reverse things back

[ 0.895032] eth-switch 400e8000.l2-switch eth0: eth0: Ethernet switch 00:14:2d:80:3c:ae

I am not sure, whit to do with it.

Found conflicts, with PWM’s zero and one, and GPIO, after removing conflicts, device is working, how it should.

Thanks for answears.

Hello ELT_ MZ,

Great thank you for sharing.

Best Matthias