VF61 linux boot problem

I am running Colibri-VF_Console-Image_2.7-20180104.tar.bz2 on Colibri VF61, and started to have boot issues a few days ago. It had been booting with no error messages, but a few days ago I started getting the following messages during boot:

[*     ] (1 of 2) A start job is running for...-ttymxc0.device (10s / 1min 30s)

(the time counts down, then I get this)

[DEPEND] Dependency failed for Serial Getty on ttymxc0.

(I also get the following)

[ ***  ] A start job is running for Load Kernel Modules (1min 35s / 3min)

(and the following)

[FAILED] Failed to start Load Kernel Modules.

What could be causing this, and how do I fix it. It first I thought the problem might be related to some small test applications I was running on the M4 core, but I took those out and the booting problem remains.

I have attached a ZIP file of everything output to the debug console during booting.link text

For your information, I had been successfully running the hello_word and gpio_sample example applications on the M4 processor core, but it seems those applications will no longer load and run since I started getting these boot up error messages.

Do you have fdt_fixup U-Boot environment variable set to something? If so - could you do at U-Boot prompt

#setenv fdfixup ;
#saveenv

I solved my own problem. I was starting up the M4 processor from Linux, and had put in an underscore ("_") instead of a minus sign ("-") in the symlink /lib/firmware/freertos-rpmsg.elf. It seems Linux does not behave well if that symlink is not found. All is working as expected now.

Perfect that the issue is solved. Thanks for the feedback.