Vf61 Connecting to Host

Hello,
I’m working with VF61 board with WinCe7 and eboot 1.64b.
I’d like to debug my program and on the PC connection I enabled the flag :
“allow connection with desktop computer when device is attached”
but when I connected the USB cable the Pc is not connected!
Are there any registers to set in order to connect the PC?
Thank you
Best regards
Matteo

Dear @Matte

I also experienced that debugging over USB ActiveSync does not work well when the PC is running Windows 10. Sometimes it takes minutes until the debugger connects, sometimes it does not work at all.

I found it much more reliable to use the debug connection over Ethernet.

Let me know if there is a reason why you cannot use Ethernet as a debug interface.

Regards, Andy

Dear @andy.tx,
thank you for you replay.
I use USB ActiveSync because our mainboard has not Ethernet Port.
We know that there are some connection problems on Win 10,
but we solved this problem with a simple batch file on the PC.
When I use WinCe6 and boot 1.5 I’m able to debug with Active Sync, but I failed with the last 1.64 and WinCe7.
Could you help me?
Best regards

Dear @Matte

Please try the process described below. Let me know up to which step you were able to successfully follow the instructions:

  1. Make sure your Colibri VF61 is not connected to any network
    (If I got you right this is the case in your system anyway)
  2. Connect your PC to the Colibri Evaluation Board (connector X29) to your development PC through a USB cable.
  3. On the Colibri, verify that a new icon appears in the system tray after a few seconds. When you double-click on it, a dialog opens saying `USB Status: Connected.
  4. On your PC, open the Device Manager. Verify that there is an entry in the tree:
    Portable DevicesColibri
  5. On your PC, start the Windows Mobile Device center (WMDC)
  6. Make Sure WMDC is showing the status Connected
  7. Make sure you can browse the Colibri’s file system by selecting in the WMDC
    File ManagementBrowse the contents of your device
  8. Start Visual Studio 2008 (VS2008), open the I2c_Demo project which is part of our Toradex CE Libraries.
    Any other project configured for WinCe would do the job, but it’s better if we both use the same test setup.
  9. In VS2008, right-click into the toolbar and activate the group Device
    It should list a device Toradex_CE600 ARMV4I Device or similar
  10. Click on the Device Options button in this tool set.
  11. Select the device which you selected in step 9. above, and press Properties…Configure….
  12. Select option Obtain an IP address automatically using ActiveSync, press OKOKOK to close all dialogs.
  13. Select ToolsConnect to Device
  14. A dialog opens, which shows the status Connection succeeded after a while.This can take up to two minutes, you might even have to repeat step 13 if it times out before.
    This time can usually be optimized by disabling all unused network adapters of your PC, such as virtual network adapters used for Virtual machines.

Regards, Andy

Dear guys,
thank you fr the support.
I followed your directions and moreover I set:

  • [HKLM\Drivers\BuiltIn\UARTC] 
    
    Dll="_vybrid_serial.dll"
  • Sodimm 137 Output 1

now it’s runs correctly also on my boards.
Are these settings rightto using in correctly way of USB connection?

Thank a lot
Best regards
Matteo

Dear @Matte
As you didn’t describe which carrier board you are using, I can only do some speculation:

  • Disabling the UARTC should not be related anyhow to the USB functionality. I can’t explain why this helped
  • Setting SODIMM 137 to high should not be required. On our boards we use this pin as an input to sense whether a USB client cable is connected. If you use your own carrier board, and didn’t design in such a circuit, then your workaround of forcing the pin to output high might be required.

Regards, Andy