VF61 and WinCE 7.0: I2C_demo start failed

Dear guys,
I tried to run the I2C_demo example on WinCe7 and VF61, but when the program calls the function:
I2c_Write() the output is :
I2C Warning: .\src\i2c_vyb.c, 148: Start failed
Is it right?
Best regards
Matteo

Dear @Matte

The warning indicates that the VF61 was not able to generate a START condition on the i2c bus.
I suspect that the i2c signals are either not pulled up, or any i2c slave is pulling the data signal low.

  • Please measure the voltage on the SCL and SDA signals (or even better, use an oscilloscope).
  • Also use the GpioConfig tool to validate the alternate function setting of the SCL and SDA signals.

Regards, Andy

Dear @andy.tx,

the PIN PTB15 is set I2C0_SDA Back and PIN PTB14 is I2C0_SCL Back

Are there any other setting to check in order to generate a START condition on he ic2_bus?
Best regards
Matteo

Dear @Matte

  • Please measure the voltage on the SCL and SDA signals (or even better, use an oscilloscope).

Regards, Andy

Dear Andy,

i did this simple test by using the Colibri evaluation board rel 3.2A and three colibri modules.
First i mounted one T20 rel 1.2A with winCe 7, power on and set the current date and time. Then i have Powered off and on and checked date and time; they were correct.
Second step: sobstituted the T20 wiith one Vf61 with Win ce6 powered on and checked date and time: they were correct.
Third step: sobstituted the WinCE 6 VF61 wiith Win CE7 V61, powered on and check date and time: the indication was: 1 January 2006. I tried to change date and time by the os menù, and it seems works but aftter power off and on it returned to 1 January 2006.
Conclusion: it seems to me that VF61 with WinCE7 has some issue about read/write the external clock on IIC and more general on peripherals on IIC.
Let me know if you need more information.
Thanks in advance
Matteo

Dear @Matte,

Please enable the debug message and share the log with us and verify is there any debug prints related to RTC sync error?

Disable the RTCSync application by setting below registry and then reboot and try to test I2cDemo application.

[HKEY_LOCAL_MACHINE\init]
“Launch48”="_rtcsync.exe"

Are you using 1.6b4 or 1.5 on Vybrid?

Meanwhile, let me test and same here and get back you soon.

Dear guys,
sorry for the delay in the reply, only now I managed to do some other tests.
In the my previous test of last my mail, I had the problem is on version 1.5.

I’ve just tried version 1.6b4 and it runs correctly also with WinCe7.

Then I compared the Sodimm’s values on the version 1.5 and 1.6b4 and
I saw that some them were different at the launch.

For this reason, I stored the configblock of the version 1.6b4
and updated the version of 1.5 with it. Also in this case the Version 1.5
the date is read correctly.

Thanks a lots for the support.
Best regards
Matteo