VF50 / 61 serial ports set to RS485 mode do not function properly

The length of the RTS signal is shorter than the length of the transmitted byte or vice versa is much longer than the transmitted byte.
Tested on VF50-128MB-v1.2 and VF61-256MB-IT-V1.1B, Vybrid WINCE6 image 1.3beta1. COM1 and COM2 exhibit the same mistake.

Green = RTS
Orange = TX

Send “U” character, 19200Bd, 8bit, 1stop, no parity


This week we plan to release new image of Vybrid. It will also address this issue.

Thank you very much for your response.

Colibri modules VF50 and VF61 are not designed for professional work.
I installed the new version 1.3 Beta 2. In this version has some RS485 works.
But work stopped NTP service. In the previous version worked.
Not working time synchronization with NTP server.
Time can not be set manually. After setting new values, the time will return to its previous value.


Iris Rev 1.1A
Colibri VF61, VF50
Win CE6

Hi, we published fix for this today including all the windows updates.

Ok? where’s the fix? Does it address this problem in Linux as well?

Hi, please do not comment on closed questions. This fix was included in our image you can download from a developers website. https://developer.toradex.com/
This fix was included in WinCE image. If you have a question related to Linux please open new question and tag it properly.