Verdin DSI to HDMI on development Board (no output)

Hi,

I’m trying to get a display working on a iMX8 but I’m actually stuck.

First I have a pre-release Verdin iMX8MM (V1.0B) and would like to know if it is possible to get it working with this board, We are currently buying the current release (V1.1A) but still didn’t received it yet.

I’m working with Yocto, Currently building tdx-reference-multimedia-image on 5.0.0-devel-202010 tag (because newer release have dropped support of this pre-release board).

Scanning for I2C Chip give me slave 48, 49, 4a, 4b and 50 when DSI to HDMI card is plugged. the address 50 is used by a driver (seems to be an eeprom driver) while 48 to 4b seems not used by kernel. Hardware seems to works fine.

Unplugging the screen doesn’t raise anything in the kernel.

Is there something to load in order to activate this output ? Or something to configure in the Yocto image perhaps ?

HI @aridet and Welcome to the Toradex Community!

Could you update to version TDX Wayland with XWayland 5.1.0+build.4 (dunfell) where the HDMI output works fine?

Unplugging the screen doesn’t raise anything in the kernel.

This is the hot plug feature which is not supported (yet) in the Software.

You can build the version 5.1 from a Tag as explained here:

https://developer.toradex.com/knowledge-base/board-support-package/openembedded-core#Update_to_a_Specific_Version_by_Using_its_Tag

Best regards,
Jaski

Hi,

I could build TDX Wayland with XWayland 5.1.0-devel-20210319081341+build.0 (dunfell) verdin-imx8mm (timestamp seem to be my compilation date), but still no output on screen (DSI to HDMI board).

Anything I could check ? Or maybe better wait for the new card.

I would add that I tried the screen on a computer and it works fine.

Latest Edit :
From the Tezi recovery I could install the build.4 and I have now a working screen. I’m now wondering with wich exact commit this image has been built? (I inited my repo with repo init -b refs/tags/5.1.0-devel-202011 -m tdxref/default.xml and it didn’t works, or I missed something)

Regards.

Hi @aridet

These are good news that your screen is working. You could compare the kernel version to know from which this was build or check this out: Link.

Best regards,
Jaski

Thank you !

Using tag 5.1.0 instead of 5.1.0-devel-202011 did the trick (I really don’t know why I picked this one the first time…).

Perfect that it worked. Thanks for the feedback.