USB problem with Apalis T30 on Ixora with Linux

Hello,

I have an Apalis T30 plugged into an IXORA carrier board and everything is working fine except the USB port in host mode on the bottom part of X8 connector. I searched for USB issues on http://developer.toradex.com/software/linux/linux-software/release-details?view=all&version=2.7b3 and I found issue #8342 interesting. The workaround ( booting with JP2 removed and only connecting JP2 after boot ) seems to solve the problem but when I reboot the device, the problem reappear and I get this message with dmesg :

[   19.721106] usb 3-1: device descriptor read/64, error -110
[   35.411146] usb 3-1: device not accepting address 2, error -110
[   35.541177] usb 3-1: new high speed USB device number 3 using tegra-ehci
[   51.121149] usb 3-1: device not accepting address 3, error -110
[   51.251198] usb 3-1: new high speed USB device number 4 using tegra-ehci
[   61.691048] usb 3-1: device not accepting address 4, error -110
[   61.831192] usb 3-1: new high speed USB device number 5 using tegra-ehci
[   72.271159] usb 3-1: device not accepting address 5, error -110
[   72.277132] hub 3-0:1.0: unable to enumerate USB device on port 1

Thanks for your help,
Dominique

Hi

What BSP version are you using?

Do all of the USB device not work or does it only happen with a specific one?

Is it working on to X8 top USB connector?

Max

Sorry, I forgot to mention that I am using BSP V2.7b3 built with OpenEmbedded without any kernel modifications.

This problem happens with a USB 3.0 flash drive (Toshiba 16 Gb) and with a FTDI USB 2.0 to UART converter. I also tried with a USB 2.0 flash drive and for this one it seems that the bug does not happen.

As described in Apalais T30 datasheet, and IXORA datasheet, the module does not provide any signals on the USBH4 interface which is connected to the top of X8. I tried to connect the working USB 2.0 flash drive but of course nothing happens.

Dominique

Are you experiencing the same issues when USB devices are connected to X7 port?

dominik.tx : No problems on X7 port !

Unfortunately there are some known incompatibilities when it comes down to USB host mode on the legacy OTG port.

Alternatively one may also use the USB port routed to the mini-PCIe slot using some adapter.

Do you have anything connected to X9? Bottom part of X8 sharing same lines as X9. Only one should be used at a time.