Update Tool for BSP 2.0 T30

Colibri T30, WCE7, BSP 2.0

Hello Toradex Community,

I’m just revising my production stick with the new updatetool. Unfortunately, I have to conclude that a simple copy paste is not enough.

My installationroutine works with the old UpdateTool without problems but with the current UpdateTool comes the following query:

Missing Product ID

Unfortunately, it is not possible to make a keyboard input during the production process.

How can I start UpdateTool without input and error message?

http://developer.toradex.com/knowledge-base/production-programming-for-tegra-modules

and

http://developer.toradex.com/knowledge-base/update-tool

Could not help me.

Thank you very much for your help.

Best regards

Saphymo

We placed that message, as it is very important to set at least the product number on the device. If you receive them from our warehouse, you should have this information already there. The modules you are facing this issue probably have been flashed with very old images or once did not fully flash which lead to this situation. So this seems to be a problem only for already touched modules.

To work around this you could use the config block editor and create a batch file, that sets the serial number before you start the update process.

You batch file would at least have to set the following information:

setconfig hw.vermaj XY
setconfig hw.vermin XY
setconfig hw.variant XY
setconfig hw.prodid XY
saveconfig hw

The best is you check the hw. setting from a existing moudule with the same version to understand which value goes whre.

The following setting is recommended. If you don’t set the serial number, you will not have a valid MAC address in the system.

setconfig mac.cid <SERIAL NUMBER>
saveconfig mac

Hello Samuel.tx,

thanks for answer.

I created a .bat File:

setconfig hw.vermaj=1

setconfig hw.vermin=1

setconfig hw.variant=a

setconfig hw.prodid=0030 Colibri T30 1GB IT

saveconfig hw

setconfig mac.cid=02750304

saveconfig mac

but it doesnt work. I will be asked about the Product ID.
How can I save this ID? Why it is deleted after every flashing?

Thanks for answer.

Best regards

Saphymo

Good morning Toradex team,

I have now tried many ways to save the version, and serial number permanently on the Colibri T30 unfortunately without success.

When entering the data manually, the data is retained until new data are collected.
Then the data must be entered again manually.

Unfortunately, this is not portable for me, since our devices have no input possibility.
The installation must be carried out automatically. How can I achieve this?

Your possibility with the .bat file does not work with me.

Many thanks for your help.

Best Regards

Saphymo

I quickly checked with the this config file, it worked fine. In the first version of the post above, I worte, you have to use “=” symbols to assign values. This was wrong, the tool only accpets spaces.

Further on, you have to provide a numeric value for the variant (0 = a, 1 = b, 2 = c, …). Does it still not work like this?

Hello Samuel.tx,

thanks for response.

I taked your file one to one. It doesnt work.

setconfig hw.vermaj 1

Cannot execute setconfig.exe

setconfig hw.vermin 1

Cannot execute setconfig.exe

setconfig hw.variant 0

Cannot execute setconfig.exe

setconfig hw.prodid 0030

Cannot execute setconfig.exe

saveconfig hw

Cannot execute saveconfig.exe

Best regards

Saphymo

@Saphymo: Seems like you try to run the batch file directly or the path to the file is not correct? Try to run it like this:

configblockeditor.exe \PATHTOFile\config.txt

You need to provide the absolute path to the file.

Hello Samuel,

thanks for response.

It doesnt work:

Cannot execute configblockeditor.exe

Best regards

Saphymo

@Saphymo : Did you use the latest tool from here. I downloaded the tool and it run well (T30, CE7). Can you open the tool in the GUI mode? Could it be you downlaoded the CE8 version of the tool?

Yes the GUI is starting.

Today the .exe runs with following error:

This SOC or BSP Vesion is not supported yet. Please update BSP

I tryed with only 30 but it dowsnt make an different.

Best regards

Saphymo

I quickly checked in the code. If you have a T30 module in the device, it can only be, that you have overwritten the config block and it can not be read any longer. This could be triggered by your recovery mode issue you are currently facing as well. Let us first solve this one, may be the situation will be also clear in this case after that.