Unable to flash with Easy Installer

Module iMX7D stopped to boot so I tried to recover. When started Easy Installer complained about an error in Config Block. After entering the data from the module’s label, Easy Installer loaded the list of images but reported the flash space 0. It can neither erase the emmc flash (error msg cannot open /dev/emmc) nor flash any image (error msg /dev/emmcblk0 does not exist).

The whole Easy Installer looks to us like unfinished software with a lot of bugs. We tried different versions on different evaluation boards and each combination behaved completely differently. On the Aster board the network was not working (Easy Installer did not get the IP address from DHCP), on some versions of Easy Installer the Update button was permanently disabled. So I don’t know if the issue is a bug in Easy Installer or the module is corrupt.

BTW, I’m evaluating modules from different manufacturers and Toradex is falling down in ranking thanks to Easy Installer. Because we no longer have a single monitor with VGA input in the company, the only way of communication is VNC. I don’t understand at all why Toradex doesn’t allow image flash without GUI. Nobody here understands why we have to flash images using some clicky tool when we only work with terminals (our systems are embedded IoT controllers without any visualization).

Hi @carnecro,

Thank you for using the Toradex community.

Could you please state which version of the Toradex Easy Installer you have been using?

For your information, the Easy Installer can also be controlled over the command line, you do not need the GUI for that. The only thing you would need is a serial connection to the board in question. From there you have all the options, which you would have when using the GUI. So there is also no need for a VGA monitor.

About the module, you are trying to flash. Is it only one unit, that has this strange behaviour, or are there multiple devices that do not seem to work as you expected?

Feel free to reach out, if you want to know more about Toradex, their SW or products. We can easily arrange a call, to answer your questions.

Best Regards

Only one module, that’s evaluation and I have no other available (just ordered 2 additional).

What about EasyInstaller we tried all that available. First, we tried version 1.8, tagged as stable. With this version, the button Install was greyed out permanently. Then we tried the latest version 5.4. On the big Colibri development board looks fine, on the Aster board I cannot get the network running, see the screenshots

I tried the nightly snapshot too with network issues on the Colibri big development board

Anyway, the 5.4 was ok so far that I could perform the actions. There are the following issues

  1. At the start, I have to update the Config Block date from the sticker. This is not persisted, the data are never saved

  1. I cannot flash the image

  1. I cannot erase the flash

Capto_Capture 2021-10-25_02-03-08_AM

Is there any chance to get the module running? Any way to re-format the eMMC flash?

Regarding VGA, we’ve used a device like this successfully with the Aster board:

This is about evaluating boards and I am not going to buy any gadgets that will never be needed again. I have too many obscure cables and converters on my desk. If you can’t flash the board with a standard USB cable without an external monitor, external keyboard and external mouse, it doesn’t make much sense to me, even during development.

The main problem is that I can’t flash the board at all, with or without VGA. The display doesn’t play any role here.