Unable to deploy application on Toradex colibri imx7 SOM on Ethernet

We have developed a smart device application on Visual Studio for Win CE 7 Colibri iMX7 Platform using Toradex CE 700 on Windows 10 Host. We are not able to deploy application on device on ethernet port, however connection with board established[Tools>>connect to device] successfully.

Below error comes on deployment:

Device is not ready. If target is an ActiveSync device, verify whether ActiveSync connection is running.

Same setup was working till last week. But it is not working now.

Dear @bipin7301

Please verify the following

  1. Disconnect any USB cable between your development PC and the Evaluation Board.
  2. Execute the Start Debugger Client application from the WEC7 start menu
  3. Verify that the IP address displayed in the dialog matches the one configured in Visual Studio

Regards, Andy

Hi Andy,

Followed the steps you have posted, but problem still same. Unable to deploy application but able to establish connection with board.

IP address displayed same after running Start Debugger Client as configured in Visual studio.

Regards
Bipin Kumar

Hi @bipin7301

Two more ideas:

  • One explanation would be some remains of a crashed ActiveSync still running in the background. Did you try to reboot your PC?
  • Try to (temporarily) disable any firewall and other security software. Maybe a Windows update since last week changed your settings and blocks now the communication.

Regards, Andy

Hi Andy,

We have disabled firewall and antivirus from our system but still problem persist.
System reboot also done.

Regards
Bipin Kumar

Hi @bipin7301
Can you try to debug a project which is known to us:

Are you able to deploy this project?

Regards, Andy

Hi Andy,

We have tried with latest Toradex CE libraries( Even with preliminary release shared on CE Libraries 2.2 - crash in Sys_GetConfigInt - #2 by andy.tx - Technical Support - Toradex Community ) and tried to deploy SysInfoLib Demo but still unable to deploy our application.

Regards
Bipin Kumar

Dear @bipin7301,

We would to like to suggest basic step by step debugging to sort out this issue

Please try below options and let us know your feedback.

  1. Try simple console hello world application and try to debug?

  2. Directly connect carrier board to PC through Ethernet cable and set static ip on both Colibri module and PC and try to debug

  3. Please try standalone application, don’t include dependency project or uncheck deployment of dependency project in the visual studio project properties.

  4. If possible, test with another PC to confirm debugging is working with toradex module.

  5. Try Visual studio administrator mode

  6. Just look in MSDN forum, you may get some clue.

  7. I guess you may not like this option, Please reinstall Visual studio and try again.

Let you know if we get any clue from our developer community.

Hi Raja,

I have performed all the steps you have suggested. But still problem persist.

Error comes on deployment of application is

ActiveSync bootstrap initialization failed. Please connect/cradle a real device or download the User-level Windows Mobile Device Center Application from http://go.microsoft.com/fwlink?linkid=67763.

I have posted this issue to MSDN form also and tried out their suggestions also. But no progress.

Regards
Bipin Kumar

Dear @bipin7301,

Could you please try registry fix recommended here: http://support.waspbarcode.com/kb/articles/windows-10-fix-summary-for-windows-mobile-device-center-issues-win10fix.

It would be more useful to us If you export those registries and sharing with us.

Hi Raja,

I have tried registry fixes you have suggested but problem didn’t solved.

We decided to move to Windows 8.1 on HOST side, but still unable to deploy application over ethernet
Error comes on deployment: “Device is not ready. If target is an ActiveSync device, verify whether ActiveSync connection is running.”

Regards
Bipin

Hi Raja,

Are the core connectivity tools required in deployment of application on Toradex platform ?

We have just installed Visual studio 2008 with required service packs but not the platform builder.

Hi Raja,

We are using static IP at device and host side both. For this scenario of deployment we need to make a target device configuration under Tools>>options>>Device Tools>>Devices and selected “Use specific IP address” option with Device IP.

While deploying application we were not selecting Target Device( the new configuration we made) and that’s why unable to deploy application. But when we selected this configuration on deployment, application get deployed.

So, we are able to deploy our application successfully now.

But, does that mean if we chose “Obtain an IP address automatically using ActiveSynch” for device configuration then it will not work ?

Regards
Bipin

Dear @bipin7301

For debugging over the Ethernet, it is required to

  • start the debug client on the Colibri
  • Note down the IP address which is shown in the dialog

[upload|tE7byX9r/XNavG4KNanOgXU3BU8=]

  • In Visual Studio, open the connection manager
  • Select Use specific IP address
  • Enter the IP address you noted down above

[upload|AHpf4kkrV5VoVqIyTGGOxIUFAW4=]

The option “Obtain an IP address automatically using ActiveSynch” does not work for debugging over Ethernet. I assume this was the only problem from beginning on.
Now that we identified the problem, it should be fine for you to connect the Colibri and your PC to an Ethernet hub, and re-enalble dynamic IP (DHCP) for both your PC and Colibri.

Regards, Andy