Unable to boot from USB on Apalis imx6 with u-boot 2019.07


I just updated my repositories to BSP 3.0b2. This updated u-boot to version 2019.07. I could install and boot the image fine with TEZI. However, after the installation, I can no longer boot from USB.

When I insert an external USB stick, I get the following output. The boot script in /boot/boot.scr is from TEZI version 3.0b2.

Apalis iMX6 # run distro_bootcmd
MMC: no card present
Card did not respond to voltage select!
starting USB...
Bus usb@2184000: USB EHCI 1.00
Bus usb@2184200: USB EHCI 1.00
scanning bus usb@2184000 for devices... 1 USB Device(s) found
scanning bus usb@2184200 for devices... 4 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found

Device 0: Vendor: SanDisk Rev: 1.00 Prod: Ultra USB 3.0
            Type: Removable Hard Disk
            Capacity: 59232.0 MB = 57.8 GB (121307136 x 512)
... is now current device
Scanning usb 0:1...
Found U-Boot script /boot/boot.scr
data abort
pc : [<2efb3096>]          lr : [<2efb2b19>]
reloc pc : [<17834096>]    lr : [<17833b19>]
sp : 2cf73220  ip : 00000003     fp : 00000000
r10: 2cfaa8a0  r9 : 2cf7eea8     r8 : 00000001
r7 : 2cfa3f38  r6 : 2bf72040     r5 : 2cf73248  r4 : 00000022
r3 : 0000005c  r2 : 2bf720a3     r1 : 2cfa3fa4  r0 : 2bf7209f
Flags: nzCv  IRQs off  FIQs off  Mode SVC_32
Code: 4630ff4d 81f0e8bd e7d84606 bf082b2f (f822235c)
Resetting CPU ...

resetting ...

When I try to run TEZI from recovery mode, then I see the following output.

Apalis iMX6 # bmode usb
resetting ...

Commercial temperature grade DDR3 timings.
Trying to boot from USB SDP
g_dnl_register: failed!, error: -19
SDP: initialize...
SDP: handle requests...

The u-boot environment is attached as a file (the output from env print). Let me know if I need to add more information.

Sorry if I missed something obvious. Any help is appreciated. Thanks a lot!

Hi @eglimi!

Thanks for contacting us.

Have you tried resetting the U-Boot environment variables? These are kept between installs so you may still have the old BSP env variables there. Running env default -a should reset them to the (new) default values. Don’t forget to saveenv before rebooting the board to save your changes.

Hello gustavo.tx,

I reset the environment to the default, which makes no difference. I think it was correct before, since the environment settings (attached to my original question) is the same as the one in uEnv.txt from the released binary (except I changed the fdt_file and vidargs resolution).

I would like to try the bootloader from the BSP release, but now I have problems flashing anything onto the module, because I cannot use USB. I’m currently trying to load and start TEZI through TFTP.


Some additional information.

I managed to start TEZI from memory and could install the Release BSP 3.0b2. I have the same problem with this installation. Here is the exact version (BSP and u-boot)

Apalis-iMX6_Console-Image 3.0b2.65 20190830
U-Boot 2019.07-3.0.2+ge1cbe8c74e (Aug 27 2019 - 01:00:06 +0000)

However, when I go back to BSP 2.8b6, starting TEZI from a USB stick works again as expected.

Apalis-iMX6_LXDE-Image 2.8b6.184 20190401
U-Boot 2016.11-2.8.6+g83a53c1c0c (Apr 01 2019 - 14:09:00 +0000)

In both cases, I reverted the environment with env default -a. This means there is the same problem with the release version.

@eglimi, can you please check the jumper JP2 on your Ixora?

The error you see when trying to run TEZI is often seen when trying to do it while having jumper JP2 on. Could you please try removing that jumper and giving it a go again?

Thank you for the suggestion. Removing the jumper JP2 doesn’t make any difference.

Hi, which version of Toradex Easy Installer are you using?

Hi @jaski.tx,

I tried both, TEZI version 2.0b2 (see OP), and version 1.8. Both versions are the official versions from the Easy Installer page.

I’m a bit stuck here, unfortunately. Somehow it seems that the new version of the bootloader has a problem with USB on my machine. I also tried different USB sticks to no avail. I didn’t try the SD card slot, since I don’t have a suitable card handy.

Does this (booting TEZI from USB with run distro_bootcmd) work with your setup with BSP 3.0B2 on this hardware? Did you have a chance to test this? I’m just not sure if it is my setup somehow, or if it can be reproduced on your side.

Many thanks!

Hi @eglimi!

There was a regression introduced in the mainline U-boot v2019.07 related to handling UTF-8 filenames, that was fixed just after the release.

Please apply the patch from (or just build the latest 2019.07-toradex-next branch) http://git.toradex.com/cgit/u-boot-toradex.git/commit/?h=2019.07-toradex-next&id=39f6f546f4ec9f3b15b6bd970da552d828311963 and let us know if you’re still facing the same “data abort” issue.

Hope it helps!

This fixes the problem. Many thanks @igor.tx!

Perfect that it works. Thanks for the feedback.