Unable to boot after upgrade to Linux 2.7 on colibri Vf

Hello,

After upgrading from Linux version 2.5 to 2.7Beta1 my Colibri Vf61 won’t boot any more. It seems to be stuck in finding DRAM. The upgrade was successful, but after power reset, it wouldn’t boot anymore.

U-Boot 2016.11+fslc+g22e68cb (Jan 11 2017 - 22:30:52 +0100)

CPU: Freescale Vybrid VF610 at 500 MHz
Reset cause: POWER ON RESET
DRAM:  

It seems to be recognizing u-boot, but it won’t go further than this stage. I can’t enter any command as well.

Note, that I have already installed the new Linux on several modules, with the exact same setup. However they were fresh installs from e-boot. This is the only one that had V2.5 installed.
I have already tried recovery mode and flashing from scratch with no success.

I have searched a bit, and saw that it could be a bug with the installed version of u-boot, but I am not sure.
Could you provide the necessary steps to get my colibri vf61 up and running again?

Thank you in advance.

Can you try the 2.7 Beta 2 image from here? A memory initialization bug fix was included in 2.7 Beta2 image which should fix the issue you are seeing.

Thank you for the answer, but I’m sorry, I don’t see any Linux image V2.7b2 from the link you provided for Colibri Vf. Only V2.5 from 2015 or in the “old” directory, V2.7b1.

The only two V2.7b2 for Colibri I am seeing are:

Colibri-VF_Console-Image_2.7b2-20170410.tar.bz2
and
Colibri-VF_LXDE-Image_2.7b2-20170410.tar.bz2

But no Linux Image, Is it one of these two?

Colibri-VF_Console-Image_2.7b2-20170410.tar.bz2 and Colibri-VF_LXDE-Image_2.7b2-> 20170410.tar.bz2

Since V2.7Beta2 release, the image names got changed.

<module-name>_<type-of-image>_<version>-<build-date>.tar.bz2

But no Linux Image, Is it one of these two?

You can use any one of the above images. Note that console only image is headless with out LXDE desktop.

This worked, thank you.