U-Boot Splash Screen on imx6ull

I am trying to display a splash screen on u-boot. But the only articleI found seems not applicable to the module I am using (imx6ull). Where are instructions for my module?
I also noticed there is no splash screen on U-boot for the image (Colibri-iMX6ULL_LXDE-Image 2.8b6.184 20190401) installed by Easy Installer. Isn’t it expected to show Toradex logo on U-boot?


For Colibri iMX6ull you can use same instruction as for Colibri iMX7 512MB

Did you mean using same article linked in my original post?

Here is what I did:

  1. Created a testlogo.png file using GIMP

  2. Coverted it to bmp format:

    $ converted testlogo.png -type Palette -colors 224 -depth 8 -compress none -verbose BMP3:testlogo.bmp

  3. Copied the bmp file to an SD card and plugged the card into card holder on Colibri Eval board

  4. Powered the board and stopped at u-boot prompt. I ran the following commands

    #mmc dev 0
    #mmc rescan
    #load mmc 0 ${loadaddr} testlogo.bmp
    #bmp display ${loadaddr}
    All commands above were excused just fine without any warnings or errors. But nothing is shown on the display. It is just a black screen.What am I missing?

Yes. Same article.

I tried different images (2.8b, 3.0). None of them show any splash screen (Toradex logo) on u-boot. Is that normal?
I followed that article as mentioned on previous post above and could not get the splash screen work. Any clue of what might be wrong?

Thank you

In Bsp 3.0, there is no display support in U-Boot but Bsp 2.8 the splash screen should work in U-Boot. Did you try to compile a custom U-Boot with your splash screen included?

Hi @wjzhang

The 8-bit depth is a hard requirement and the screen doesn’t display anything if your converted image doesn’t have a 8-bit depth. The parameter -depth 8 doesn’t always work properly as mentioned here. Could you check the bit depth of your converted image and apply the workaround described in the link above when it’s not 8? You can e.g. check the metadata of your image here and check the value of
“Bits Per Sample”.

Best regards

Below is metadata check result:

File Size21 kB File TypeBMP File Type Extensionbmp Mime Typeimage/bmp Bmp VersionWindows V3 Image Width320 Image Height64 Planes1 Bit Depth8 CompressionNone Image Length20480 Pixels Per Meter X19685 Pixels Per Meter Y19685 Num Colors256 Num Important Colors256 Image Size320x64 Megapixels0.02 Categoryimage Raw Header42 4D 36 54 00 00 00 00 00 00 36 04 00 00 28 00 00 00 40 01 00 00 40 00 00 00 01 00 08 00 00 00 00 00 00 50 00 00 E5 4C 00 00 E5 4C 00 00 00 01 00 00 00 01 00 00 ED ED F5 00 EE EE F5 00 ED ED

It’s showing that the splash BMP file is already in 8-bit depth format.What else should I check?

Yes, I was trying to compile a custom U-Boot with our splash screen included.However, the problem I have is that I don’t even see the default Toradex logo splash screen with the version 2.8b6 image pulled out from Toradex server without any customization.

By the way, I did compile a custom kernel with our splash screen included. It worked just fine without any issues.

Hi @wjzhang

Could you share your U-boot splash screen image?

Thanks and Best regards,

Here is the bmp file for splash screen. Thank you.

Thanks for the file. I will try to reproduce the issue and come back soon to you.
Thanks for your patience.

.However, the problem I have is that I don’t even see the default Toradex logo splash screen with the version 2.8b6 image pulled out from Toradex server without any customization.

I tested this with Bsp 2.8b6 using the Aster Carrier Board and Toradex Logo is present on the capacitive touchscreen.

Which carrier board did you use?

Best regards,

I tested this at my place and a the logo LifeLoc is present at my place.
I think there is issue regarding your hardware/software settings.

Best regards,

Can I have your u-boot image to test at my place?

I am using Colibri Eval board.Is the image you tested the demo one with LXDE?

I just installed the regular Bsp 2.8b6.

What could be wrong? I am using Colibri Eval board with the module and the factory 2.8b6 image loaded by Easy Installer. Nothing has been customized yet.
Let me make it clear. When you stop the u-boot at the prompt, do you see any splash (logo) screen on your monitor?

Yes. I see splashscreen when stopped in U-Boot. But I tested on Aster Carrier Board. Let me test this with Evaluation Board again.

Best regards,

Hi @wjzhang

I don’t see any Splash Screen on the VGA Monitor but on the Capacitive Touchscreen. It seems to be the same for iMX7.

Best regards,