U-boot partition for fw_setenv misleading

Hello,

I try to set the u-boot env via fw_setenv.
On my Tegra board I have these partitions
ls /dev/mmcblk* /dev/mmcblk0 /dev/mmcblk0boot0 /dev/mmcblk0boot1 /dev/mmcblk0p1 /dev/mmcblk0p2 /dev/mmcblk0rpmb

and these versions:
Tegra124 Linux R21.6.0 armhf

This post leads to the default fw_env.config but to an access violation:
http://git.toradex.com/cgit/meta-toradex-tegra.git/tree/recipes-bsp/u-boot/files/tegra124/fw_env.config?h=morty

/dev/mmcblk0boot0 -0x2200 0x2000

This post leads to a different one which leads to CRC warnings and a difference between boot prompt printenv (no changes) and Linux fw_printenv (changes saved):
https://www.toradex.com/community/questions/16737/how-to-write-u-boot-environment-variables-with-fw.html

/dev/mmcblk0 0x80000 0x2000

Can you give me a hint which configuration might be the right one?

regards
Dirk

One may not simply mix and match various such settings across different module types and/or BSP versions. While the former represents the current setting as used on Apalis TK1 the later refers to the Apalis iMX6 and the particular setting you refer to stems from the meanwhile obsolete V2.5 beta BSP.

Ok:

The default /dev/mmcblk0boot0 -0x2200 0x2000 is correct. After updating the kernel again into a clean state no access violation occurs anymore. I don’t know how this can happen simply by using:

Apalis TK1# setenv newVariable1 newValue1

Linux# fw_setenv newVariable2 newValue2

without modifying default addresses or parameters