Two additional ASIX USB2Ethernet ports

We need 3 Ethernet ports instead of the single Eth port available on the Iris board. We are trying to use two ASIX USB2Eth dongles connected to a 1:7 USB Hub plugged to the Iris USB port.

With this two dongles plus the existing Ethernet port on the Iris board we would achieve 3 Eth ports.

However, in trying to test the throughout with w WCE 7 browser and running a simple internet speedtest, we have noticed that the two additional ports allow the browser to reach the internet for a few seconds but then loss internet connection. The Iris board port works fine.

Ping using the two new ports also works initially but generates transmitt or receiv errors after the first few successful pings.

Any ideas?

Additional info: we are using Zetakey browser to try to connect using each of the 3 Ethernet ports and measure the throughput for each. In doing these tests we have noticed that the two additional ASIX ports allow the connection (with the Zetakeybrowser) to 2-3 pages and then internet connection is lost.

We never tested having more than two two Ethernet connections. I suspect one of two possible reasons for the failure: USB overcurrent, or duplicated MAC addresses.

  • Does each of the external Asix dongles work fine, if you only connect one of them?
  • Did you try to use a powered USB hub?

You can verify the Ethernet adapter’s MAC addresses (Physical Addresses) by clicking on the icons in the system tray and select [Details…]. Are they all different?

If you don’t find a problem, please do the following steps:

  • Open a WinCE command line and type

    ipconfig /all >ipconfig.txt
  • Open the registry editor and export the key [HKEY_LOCAL_MACHINE\Comm] to a file comm.reg
  • Please post the two files ipconfig.txt and comm.reg here.

Thank you for your message. The problem seems solved now.
Our USB Hub is powered, so excessive current draw could not be the problem.

We first tested with one dongle only, it worked.

Then we checked the MAC addresses, and that was it. Both dongles used the same MAC. To solve it we editted the registry and set different MACs for each dongle.

Thanks again!