Trying to use debug serial port leads to board shutdown

I use a Verdin development board with IMX8MMDL 1GB IT.

The board seems to start correctly when I plug the power, but if I plug a USB-C cable in X66 to get Debug serial line, the board stops as soon as some software opens the /dev/ttyUSB0 device (tested with gtkterm and minicom).

In fact when starting the software all leds turn off except +V5 STB and debug leds.

Any idea about such a problem ?

Hello @cch

Which SoM and carrier board version do you use?

Do all the LED’s next to the ON/OFF button light up?
How are you powering the board (voltage and intensity)
Do the Tx and Rx LEDS flash when you reset the board?
Is the JP30 in the 1-2 position (1.8V DBG)?
Have you tried using another USB cable? Or have tried the same USB cable with another device to rule out the possibility of a defective cable?
Have you tried with another module? (if you have more than one)

Best regards,

Hello @josep.tx.

The SOM I use is Verdin IMX8MM DL 1GB IT V1.1B serial number 06944094.
The board is Verdin Development Board V1.1C SN 10952569.

The power is 12 V 3A, and when I plug it all the leds near On/off light up.

When I reset the board, the Leds C.TX, C.RX, D.TX and D.RX in the debug area don’t flash.

I have tried with another USB cable, same result.
JP30 is in the 1,8 DBG position.

I can’t try with another module, I don’t have another one.


Hello again @josep.tx , browsing the Toradex community site I have found the solution.

The reset of the board was because I opened /dev/ttyUSB0. If I connect to /dev/ttyUSB3 I get the correct serial line (linux console).

I found the solution in this post : Verdin Development Board Serial Debug Port.


This is the reason why I asked Toradex to change the info in page Serial Terminal Emulator | Toradex Developer Center, changing /dev/ttyUSB3 into /dev/ttyUSB0.
Following exactly the instruction on that KB page reboots the SoM, and this is frustrating.

1 Like

Hello @cch ,
I reopen this topic just to note that the behavior that you were experiencing is documented here:

Best regards,

thanks for the pointer. Nevertheless it’s quite unusual, as with most boards /dev/ttyUSB0 is the serial line for debug, so it’s easy to generate a reset if we don’t find this article.
For me I’m know aware of the solution.