Troubles with Resistive Touch Display 7" Parallel V1.0A for Apalis iMX6 with Apalis Evaluation Board

Hello,

Last week I received the Resistive Touch Display 7" Parallel V1.0A. I tried to install the display but I got no screen. I followed this article: Display Output, Resolution and Timings (Linux) | Toradex Developer Center

Maybe can someone help me and say me what I am doing wrong

Pictures below:

link text

Could you please provide more details?

What Linux version you are using?
Does it boot successfully?
Have you tried to connect VGA or DVI display?
Which display parameters did you try?

Thanks four your reply.

I am using Linux: Linux Version:4.1.44-2.7.4+gb1555bf (yocto@45574f02061f)

I am able to use a DVI display.

Parameters: I think I used the standard. I tried this:

video=mxcfb0:dev=lcd,EDT-WVGA,if=RGB24
video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24

setenv vidargs 'mxc_hdmi.only_cea=1 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24
video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M' (error)

video=mxcfb0:dev=ldb
video=mxcfb0:dev=ldb,bpp=32

Please try

setenv vidargs 'video=mxcfb0:dev=lcd,EDT-WVGA,if=RGB24 video=mxcfb1:off video=mxcfb2:off video=mxcfb3:off fbmem=32M'
saveenv
boot

And double check if a flat cable connected correctly.

Dear Alex,

Thanks for your reply. It works now!