Trouble getting "older" project to run

Hi,

I have a project from the first week of December, that I’ve started working on again today. I opened the folder with Visual Studio Code and the latest Torizon extension loaded. I selected the command “Torizon: rebuild SDK and load in container” Now, when I start debugging my application, I get this error:

/home/merijn/.vscode/extensions/toradex.torizon-1.4.0/moses-linux/moses '--port', '5000'" terminated with exit code: 255.

No image is transferred to the connected Verdin module and (obviously) no container is created.

Running Torizon extension 1.4.0 on VSCode 1.66.2 on a fully updated Ubuntu 20.04.4 LTS

Returned to the project I was working on without errors just yesterday, and I can’t get that to run either! I get the following output:


[2022-04-27T11:44:05.278Z] Step 1/3 : FROM myproject_arm32v7-debian-no-ssh_bullseye_debug_68079114-658b-4c15-a2b4-84ab1c41a410_sdk_image
[2022-04-27T11:44:07.409Z] pull access denied for myproject_arm32v7-debian-no-ssh_bullseye_debug_68079114-658b-4c15-a2b4-84ab1c41a410_sdk_image, repository does not exist or may require 'docker login': denied: requested access to the resource is denied
[2022-04-27T11:44:07.414Z] Stop (2959 ms): Run: docker build -f /home/merijn/Documents/myproject/myproject/.devcontainer/Dockerfile -t vsc-myproject-d03333c8764949595d33d7056b0f8286 /home/merijn/Documents/myproject/myproject/.devcontainer
[2022-04-27T11:44:07.419Z] Error: Command failed: docker build -f /home/merijn/Documents/myproject/myproject/.devcontainer/Dockerfile -t vsc-myproject-d03333c8764949595d33d7056b0f8286 /home/merijn/Documents/myproject/myproject/.devcontainer
[2022-04-27T11:44:07.419Z]     at Lu (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:219:3210)
[2022-04-27T11:44:07.420Z]     at processTicksAndRejections (node:internal/process/task_queues:96:5)
[2022-04-27T11:44:07.421Z]     at async xR (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:219:1558)
[2022-04-27T11:44:07.421Z]     at async Hw (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:219:585)
[2022-04-27T11:44:07.422Z]     at async IR (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:224:2024)
[2022-04-27T11:44:07.423Z]     at async Xw (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:224:3221)
[2022-04-27T11:44:07.424Z]     at async kR (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:224:13925)
[2022-04-27T11:44:07.424Z]     at async TR (/home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js:224:13650)
[2022-04-27T11:44:07.437Z] Stop (4235 ms): Run: /snap/code/94/usr/share/code/code /home/merijn/.vscode/extensions/ms-vscode-remote.remote-containers-0.231.6/dist/spec-node/devContainersSpecCLI.js up --container-data-folder .vscode-server/data/Machine --container-system-data-folder /var/vscode-server --workspace-folder /home/merijn/Documents/myproject/myproject --workspace-mount-consistency cached --id-label vsch.local.folder=/home/merijn/Documents/myproject/myproject --id-label vsch.quality=stable --log-level debug --config /home/merijn/Documents/myproject/myproject-speech/.devcontainer/devcontainer.json --remove-existing-container --mount type=volume,source=vscode,target=/vscode,external=true --skip-post-create --update-remote-user-uid-default on --mount-workspace-git-root true
[2022-04-27T11:44:07.439Z] Exit code 1

This output suggest to run ‘docker login’ so I did that in a new terminal, but that didn’t help (or I did it wrong?)

I don’t know of any change to my build environment. What am I missing? What can I do to fix this?

Hi @mvandenabeele , hope you’re doing well!

Thanks for reaching out Toradex Community. In order to help you further with your problem, I’ll ask you a few questions about it.

  • Have you tried uninstalling and reinstalling the extension to check if any package would been deleted in the meantime?
  • In addition, if we got it well, you’re using a Verdin iMX8M-Mini with Torizon. Did you change the module recently? It seems to us that you’re trying to compile However, it seems to us that you’re trying to compile using the Arm32 SDK as seem in the output: FROM myproject_arm32v7.
    • Usually it should be arm64 for Verdin Modules. Could you please create a new project using the correct SDK and check if this solves your issue? You can copy your files once the project is created and test it again.

Thanks a lot.

Best regards,
Guilherme

Hi Guilherme

Thanks for your reply.

I had uninstalled the extension; tried a previous version and then uninstalled it to reinstall the latest version. All steps finished without errors. The project was always based on arm32v7 and it worked, but since you suggested arm64 would be better for Verdin, I switched to that this morning but it didn’t help.
That is to say, it still doesn’t compile but I do get different behavior. When I press F1 and run the command ‘Torizon: Rebuild SDK and reload’, I get the following output:

[18595 ms] Start: Run in container: /bin/sh -c mkdir -p /home/torizon/.vscode-server-insiders/extensions ; mkdir -p /home/torizon/.vscode-server/extensions; ln -s /home/torizon/.torizon-extension /home/torizon/.vscode-server-insiders/extensions/toradex.torizon ; ln -s /home/torizon/.torizon-extension /home/torizon/.vscode-server/extensions/toradex.torizon ; chgrp docker /var/run/docker.sock ; true
chgrp: changing group of '/var/run/docker.sock': Operation not permitted

Does that ring a bell?

Merijn

As a test, I created a new VM with Ubuntu 22.04 LTS, installed docker, Visual Studio Code and the Toradex extension, and I’m getting the same error. When VS Code starts I get these notifications:

image

And then a little later

image

In the lower left corner of VSCode there’s this forever:

image

I followed the getting started guide to the letter so I don’t think I did anything wrong. What can I do to solve this?

Hi @mvandenabeele, how are you?

Ubuntu 22.04 is currently not supported on the Visual Studio Code Extension. There was a package conflict between the last releases of Ubuntu and the new LTS that we’re working on to get everything on point for customers.

However, as you said that you’re trying at first on Ubuntu 20.04.4 LTS, I’d like you to do two things:

  1. Can you please check that no application is using port 5000 on your PC when you try to open the extension? You can do this by typing: sudo lsof -i -P -n | grep LISTEN. If there is something that appears, it may be causing a conflict with the extension backend.

  2. If there is anything that show up, can you please try to run moses separately and give me any log that pops out? You can find the path to moses by typing: ls -alh ~/.vscode/extensions/toradex.torizon-*/moses-linux/moses

Best regards,
Guilherme

Everything is working as it should…

That’s good to hear!

So can you please interrupt Moses and try to open the extension again to check if the following error stops appearing?

About the new error that appears, can you please try to press F1 and run the following command: Developer: Reload Window and tell me if the error appears again when you try to rebuild again?

Best regards,
Guilherme

After running “Developer: Reload Window” I was able to get things running again, but it was a lucky shot. I closed VSCode to do the test again and didn’t succeed after three tries.

Now, when I open my project folder and run “Toradex: Rebuild SDK and reload in container” I get

Running the postCreateCommand from devcontainer.json...

[3799 ms] Start: Run in container: /bin/sh -c mkdir -p /home/torizon/.vscode-server-insiders/extensions ; mkdir -p /home/torizon/.vscode-server/extensions; ln -s /home/torizon/.torizon-extension /home/torizon/.vscode-server-insiders/extensions/toradex.torizon ; ln -s /home/torizon/.torizon-extension /home/torizon/.vscode-server/extensions/toradex.torizon ; chgrp docker /var/run/docker.sock ; true
chgrp: changing group of '/var/run/docker.sock': Operation not permitted

Done. Press any key to close the terminal.

Dear @mvandenabeele ,

This is a current bug that has started to happen on the extension recently after a new VS Code Update. We’re currently working to get fixed. As from today, it could be nice to check if you can see Torizon Logo on the left-side of your VS Code as in the screenshot below.

image

If it shows there, you should be able to run the command that you wish to. However, if you can’t see the logo or if you get the same error message again, the current workaround is to do the Developer: Reload Window once more.

We can get back to you once the bug is fixed if you wish to.

Best regards,
Guilherme

Thanks for the heads-up. The Torizon logo is always there but to run a command successful needs a lot of luck, even with the reload-window-workaround. Hope you get the bug fixed soon. Please keep me informed of any progress.

@gclaudino.tx Any news on this? Can I help to get this fixed?

Dear @mvandenabeele ,

After discussing with the team, they stated that the fix would be in the Early Version of the Torizon Visual Studio Code Extension. Can you please change to the Early Access Version and check if you can use it without problems?

In addition, if you want, you can use Ubuntu 22.04 with the extension now. The documentation has been updated on how to enable it: Visual Studio Code Extension for Torizon | Toradex Developer Center.

Best Regards,
Guilherme

Thanks for the update. Visual Studio Code 1.67.0 was released and that seems to have fixed it too. At least now I can use the reload window workaround. I’ll stay on the main branch for now. Good to know Ubunto 22.04 is now supported!

1 Like

It seems I was a bit too excited about this… I got one project to compile, build and debug a whole day. Now I wanted to switch to another - similar - project, and I got the same problems as before. I installed the early access version of the extension but it didn’t help either. Exactly the same result as with the official version, and exactly the same problems on Ubuntu 18.04 and 22.04.

Dear @mvandenabeele ,

I’m sorry things stopped working again. Just to be sure about it, are you using the early access version 1.5.204? This is the last merge we made and where the fix should be available. In addition, have you tried the workaround of refreshing the window at least once on this other project?

According to our team, the fix changes how the extension is installed by changing a few json parameters of old projects. Once the extension with the fix is loaded (after a window reload) it should rewrite the devcontainer.json file and then you’d be able to keep working without any major problems. New projects created after the fix should be fine.

The error logs are still the same?

Thanks again.

I had 1.5.203 this morning. Uninstalled everything and re-installed the early access extension which is now 1.5.205. I always get this error:
image
Running the commands you asked me to run in the beginning gave me this output:


This is on a fully updated Ubuntu 22.04 with VS Code 1.67.1

BTW. The link to libssl1.1l in the installation instructions should be http://security.ubuntu.com/ubuntu/pool/main/o/openssl/libssl1.1_1.1.1l-1ubuntu1.3_amd64.deb I think. The current link gives a 404. Running the install command however gave


I’m not sure if that went okay.

Now I gave it some time and then reloaded the window, and that might have helped. I imported my old project from github and I think updating the project has some issues too…

I’m now facing a spinner that says “Building SDK container” I’ll give it some time and report back.

I’d like to add: created a new project from scratch but can’t get that to run either.

And because I desperately want to get working on our project, I tried creating a new project in a Windows environment. This gave me


I saw this error on Ubuntu too.

Dear @mvandenabeele ,

Thanks for the update. Indeed the link that was on the page was broken. We corrected it.

This issue is linked to an error on the devcontainer.json file. Can you please follow the steps on the video below to check if you can get things back running? Remember to use the Easy Installer Early Access Extension.

Best regards,
Guilherme

When I did this in my newly created project, it started working. My old project didn’t even have a .devcontainer and the .vscode folder was missing most files too. I copied the missing files from the new working project and now it does look a lot better. I’m still having issues with CMake not behaving as it used to, but I’ll look at that today.

On a side note: do I need to put .devcontainer and .vscode in my git repository then? I was under the impression that those files would automatically be recreated if needed.

I tried going through the getting started instructions on my home laptop and I get exactly the same issues. I thought, maybe it’s something not seeing, so I asked a colleague to do the same in his development environment, hoping he would do something different, but still we get the same results. Could you please follow your guide on a clean Ubuntu and see what is happening?

Also, the URL to download libssl is changed in the wget command, but not in the next command where the package should be installed. Please note, as stated before, that the installation ends with an error. I’m not sure if it’s a big problem. It doesn’t matter too much as I can’t get it to work in older Ubuntus either.

I already lost a lot of time on this, so I really hope you guys can spot something I’m not seeing to get this fixed in a timely manner.