Trace back repo sync problem


Is there any problem in repo?
I am following these steps just as usual to build yocto image for tk1 module
BSP 2.8 tab
when i run
repo sync
command , i get this trace back error

Fetching projects: 100% (17/17), done.
fatal: failed to unpack tree object HEAD
error: Cannot checkout meta-qt4: GitError: Cannot initialize work tree for meta-qt4
Traceback (most recent call last):
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 541, in
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 516, in _Main
result = run()
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 509, in
run = lambda: repo._Run(name, gopts, argv) or 0
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 212, in _Run
result = cmd.Execute(copts, cargs)
File “/home/ugv/oe-core_lxde/.repo/repo/subcmds/”, line 994, in Execute
self._Checkout(all_projects, opt)
File “/home/ugv/oe-core_lxde/.repo/repo/subcmds/”, line 553, in _Checkout
File “/home/ugv/oe-core_lxde/.repo/repo/subcmds/”, line 435, in _CheckoutWorker
return self._CheckoutOne(opt, project, args, *kwargs)
File “/home/ugv/oe-core_lxde/.repo/repo/subcmds/”, line 469, in _CheckoutOne
project.Sync_LocalHalf(syncbuf, force_sync=opt.force_sync)
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 1532, in Sync_LocalHalf
self._InitWorkTree(force_sync=force_sync, submodules=submodules)
File “/home/ugv/oe-core_lxde/.repo/repo/”, line 2784, in _InitWorkTree
raise GitError('Cannot initialize work tree for ’ +
error.GitError: Cannot initialize work tree for meta-qt4

Hi @rama.aloufee!

I did a quick test and I was able to pull everything from the LinuxImageV2.8 branch of Index of /toradex-bsp-platform.git. Maybe you got a hiccup from your internet connection?

hi @henrique.tx ,
I’ve found the solution here.
it was something related to CA certification updates
it worked for me now
thank you

1 Like

Thanks for sharing!

Best regards,