TorizonCore remote access AP mode

I’d like to configure my device as an access point and remote into it. I followed the instructions on:

It does create an AP, but when it assigns an IP to my PC it’s not on the same network.
for example:
ifconfig on my Torizon Device my ip is on uap0 net mask
ipconfig on my PC my ip is net mask

Obviously, I’m doing something wrong. The goal is to make the torizon device an AP and have my PC connect to it. then ssh into the torizon device.

ideas?? is link local address, which windows assign when DHCP server is not available. Did you follow as well what is suggested in the same instructions starting from

Besides a Wi-Fi access point, you also need to activate a DHCP server in TorizonCore. To do that, …

Yes I did. This is it:




Then perhaps systemd-networkd isn’t working. You may check it with

systemctl is-active systemd-networkd

Try starting it with systemctl start systemd-networkd. Though I don’t know how network manager may interact with it. From your description clearly DHCP server isn’t working. You may use any one, not necessarily systemd-networkd.

I ran systemctl is-active systemd-networkd and it said active. I even stoped and started it again, and then reconnected to the AP. Still does not work.

any other ideas?

I believe the issue is the Address= field in your network file. I tried using your network file, and when I checked the log messages for systemd-networkd I saw the following message:

Invalid address '', ignoring assignment: Invalid argument

I checked and in network files instead of specifying the full netmask you instead need to provide the shorthand version for example:


Once I made this change, the access point appears to work and distribute IP addresses accordingly. At least on my setup.

Best Regards,