Torizoncore-builder command not found

Colibri iMX6DL 512 MB IT v1.1B
Colibri Evaluation Board

I have been automating my WSL environment so that I always get the right build environment set up to use torizoncore-builder.

It has worked well in the past, but lately I am getting

torizoncore-builder: command not found

the commands I run in a .sh script are:

#! /bin/bash

sudo apt-get update && sudo apt-get install rsync ssh
# sudo apt install openssh-client
docker --version
docker run hello-world
docker run --rm -it --privileged torizon/binfmt
docker run --platform linux/arm/v7 --rm -it arm32v7/debian arch
docker run --platform linux/arm64/v8 --rm -it arm64v8/debian arch
source ./

# the following should be typed by hand
# torizoncore-builder dt checkout
# rm -vr output_directory
# torizoncore-builder build

Everything seems to work, and I get the message:

Setup complete! TorizonCore Builder is now ready to use.
TorizonCore Builder internal status and image customizations will be stored in Docker volume named 'storage'.
Important: When you run TorizonCore Builder, the tool can only access the files inside the current working directory. Files and directories outside of the current working directory, or links to files and directories outside of the current working directory, won't be visible to TorizonCore Builder. So please make sure that, when running TorizonCore Builder, all files and directories passed as parameters are within the current working directory.
Your current working directory is: /home/leighjboyd/tcbworkdir
For more information, run 'torizoncore-builder -h' or go to
leighjboyd@EMERALENOVO11:~/tcbworkdir$ torizoncore-builder
torizoncore-builder: command not found

and when I echo $PATH i get:

/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games:/usr/lib/wsl/lib:/mnt/c/Windows/system32:/mnt/c/Windows:/mnt/c/Windows/System32/Wbem:/mnt/c/Windows/System32/WindowsPowerShell/v1.0/:/mnt/c/Windows/System32/OpenSSH/:/mnt/c/Program Files/Docker/Docker/resources/bin:/mnt/c/ProgramData/DockerDesktop/version-bin:/mnt/c/Program Files/PuTTY/:/mnt/c/Users/LeighBoyd/AppData/Local/Microsoft/WindowsApps:/mnt/c/Users/LeighBoyd/AppData/Local/Programs/Microsoft VS Code/bin:/mnt/c/Users/LeighBoyd/AppData/Local/Programs/Git/cmd:/mnt/c/Users/LeighBoyd/AppData/Local/GitHubDesktop/bin:/snap/bin

I restarted my computer and it gave the same results.

Could not find it like this either:

root@EMERALENOVO11:/# find . -iname "torizoncore*" -type f 2>/dev/null

Greetings @leighjboyd,

This script you’ve made how are you executing this? I believe you need to source this script similar to how the torizoncore-builder setup script is sourced. Otherwise the torizoncore-builder command won’t be available after the script has completed.

Best Regards,

Yes, it needed to be sourced! Thanks again!

in other words:

source ./

Glad I could help!