Torizon IDE Extension: Open Terminal not working anymore

I use Torizon IDE Extension v2.4.2 on my Windows 10 PC with WSL backend.
Everything works fine, but I noticed that on the new releases (it seems to me from v2.4.0, but I can be wrong), the command Open Terminal doesn’t work anymore.
immagine
I see that a script is launched in the terminal, but it’s really fast before it disappears.
And the terminal stays on my WSL.
I can easily ssh connect to the Verdin from the same terminal
ssh torizon@192.168.137.xxx
to get a terminal on the SoM.

Which is the script launched when I click Open Terminal?

With older release of Torizon IDE Extension, Open Terminal worked as expected, and I used it several times.
I don’t know if this is related, bu my PC has multiple ethernet interfaces and so I had to set
"host_ip": "192.168.137.1"
in settings.json

Hi, I’m the Toradex AI Assistant. I’m in early beta, and I would appreciate your feedback.
The Toradex Support team will follow up with you shortly!

Did you like my answer?

:+1: :-1:


Hello,

The issue you’re encountering with the “Open Terminal” command in the Torizon IDE Extension v2.4.2 might be related to changes or updates in the extension itself or its interaction with the WSL backend and the Visual Studio Code environment. When you click “Open Terminal,” the extension typically executes a script designed to establish a terminal session directly into your target device, in this case, a Verdin module. This script usually handles the SSH connection setup, leveraging the configuration specified in settings.json, including the host_ip address.

Given the behavior you described, it’s possible that the script execution encounters an issue with the new version of the extension or there’s a conflict with your system’s configuration, especially considering the multiple Ethernet interfaces and the specific host_ip setting.

While I cannot provide the exact script that is launched (as this might vary between versions and is not explicitly documented), the script’s purpose is generally to automate the SSH connection to your device using the provided IP address and default credentials (unless changed) for the Torizon environment.

To troubleshoot this issue, consider the following steps:

  1. Review the settings.json Configuration: Ensure that the "host_ip" setting correctly reflects the IP address of the interface used to communicate with the Verdin module. Misconfiguration here could lead to connection issues.

  2. Check for Extension Updates: Although you’re already on v2.4.2, ensure there are no newer updates or patches for the Torizon IDE Extension that might address this issue.

  3. Manual SSH Connection: Since you can successfully connect via SSH manually, use this method as a temporary workaround. This confirms that the network configuration and credentials are correct, isolating the problem to the extension or its interaction with your system.

  4. Visual Studio Code and WSL Configuration: Ensure that your Visual Studio Code and WSL setup are correctly configured and up to date. Compatibility issues or misconfigurations here can affect extensions.

  5. Extension and VS Code Console Logs: Check the Visual Studio Code’s output and debug console for any errors or warnings that might provide more insight into what happens when the script is executed.

  6. Network Configuration: With multiple Ethernet interfaces, ensure there’s no IP address conflict or routing issue that might prevent the extension from correctly establishing the SSH connection.

If the problem persists after these steps, it might be beneficial to look for any known issues reported by other users that could shed light on this specific problem or any potential workarounds that have been

Please, also check if these links can help you solve your problem:

Connect a Target Device | Toradex Developer Center.

Greetings @vix,

I just tried this myself and couldn’t reproduce it. I made sure I have v2.4.2 of the extension and I have 6.6.1 Torizon OS running on my device. The Open Terminal button works as expected in my setup.

I don’t know if this is related, bu my PC has multiple ethernet interfaces and so I had to set

I do not have multiple interfaces in my setup so perhaps this could be a factor/cause? I’ll check with our IDE team if they have any comments on this.

Best Regards,
Jeremias

1 Like

Hey @vix

the terminal connects using the hostname instead of the IP address. So, try to connect using the hostname from a new terminal, to check if it behaves like the IDE extension button.

We are discussing on the team if make sense to change this to use the IP address instead.

BR,