Torizon Core Build Error - Bitbake


I am trying to build the torizon core image as outlined in the following link but running into bitbake errors when the build starts. All prerequisite libraries have been install and when running the bitbake command within the [BUIILDDIR] the following message occurs along with some python errors. Machine is setup for imx7 when the setup script is run. I have tried this on ubuntu 20 and 18 Os but still the same error.

ERROR: Unable to start bitbake server (None)
ERROR: Server log for this session (/home/mc/[BUILDDIR]/bitbake-cookerdaemon.log):
--- Starting bitbake server pid 9666 at 2021-01-12 23:59:22.917607 ---
ERROR: Error in compiling python function in /home/mc/[BUILDDIR]/conf/../../layers/openembedded-core/meta/conf/machine/include/arm/, line 10:

The code lines resulting in this error were:
 *** 0001:def __anon_20__home_mc_[BUILDDIR]_conf_______layers_openembedded_core_meta_conf_machine_include_arm_feature_arm_thumb_inc(d):
     0002:    if bb.utils.contains('TUNE_FEATURES', 'thumb', False, True, d):
     0003:        return
     0004:    selected = d.getVar('ARM_INSTRUCTION_SET')
     0005:    if selected == None:
SyntaxError: invalid syntax (, line 10)
WARNING: /home/mc/bitbake/lib/bb/server/ ResourceWarning: unclosed file <_io.TextIOWrapper name='/home/mc/[BUILDDIR]/conf/../../layers/meta-toradex-nxp/conf/machine/colibri-imx7-emmc.conf' mode='r' encoding='UTF-8'>
  return None

WARNING: /home/mc/bitbake/lib/bb/server/ ResourceWarning: unclosed file <_io.TextIOWrapper name='/home/mc/[BUILDDIR]/conf/../../layers/openembedded-core/meta/conf/bitbake.conf' mode='r' encoding='UTF-8'>
  return None

bitbake torizon-core-docker

I do not see much about this error so any help would be appreciated.


Greetings @bigmc,

This is interesting we haven’t seen such an error in our own test builds recently.

What version of TorizonCore are you building? Your link points to Torizon 4.0 but I just want to confirm.

Also if it is 4.0, then may I ask why you are building 4.0 instead of our up-to-date 5.0?

Best Regards,