Toradex images via Easy installer not working (zImage not found)

Just started with i.MX6 on Apalis carrier and tried to install some Toradex images via Easy Installer. Easy installer itself and embedded Linux Demo 2.8b2.97 work fine, but the stable version 2.7 will not start after programming. Also other images will be programmed, but after reboot I only see the Toradex Logo and the following output on the console (minicom on host computer):

U-Boot 2016.11-2.7.4+g1b121c6 (Oct 04 2017 - 22:34:15 +0000)
CPU:   Freescale i.MX6Q rev1.5 at 792 MHz
Reset cause: POR
I2C:   ready
DRAM:  2 GiB
PMIC:  device id: 0x10, revision id: 0x21, programmed
auto-detected panel HDMI
Display: HDMI (1024x768)
In:    serial
Out:   serial
Err:   serial                                                                                       
Model: Toradex Apalis iMX6 Quad 2GB IT V1.1C, Serial# 05184610                                      
Net:   using PHY at 7                                                                               
FEC [PRIME]                                                                                         
Hit any key to stop autoboot:  0                                                                    
Booting from internal eMMC chip...                                                                  
reading imx6q-apalis-eval.dtb                                                                       
50345 bytes read in 17 ms (2.8 MiB/s)                                                               
reading zImage                                                                                      
** Unable to read file zImage **                                                                    
emmcboot failed                                                                                     
MMC: no card present                                                                                
MMC: no card present                                                                                
starting USB...                   

After programming I were asked to reboot or power down. Reboot will not restart, I always have to press the power button to start the new programmed image

You are basically suffering the reverse of the following which may be worked around exactly the same way e.g. by doing the following on the U-Boot command line:

env default -a

Due to the switch from uImage to zImage in 2.8b2 (see #17925), after upgrading to 2.8b2 the U-Boot environment tries to load the zImage still.

You need to reset the U-Boot environment by using the following commands in the U-Boot console:

env default -a
env save

Reboot does not work when using the recovery mode. See also the message at the end when flashing an image:


Thanks to @stefan.tx and @marcel.tx.

boot_file=uImage did the trick for older images

You are very welcome.