Toradex extension not starting up

I am following the Quickstart-guide.
I installed the “Toradex Torizon Support” extension to VSCodium running on a Fedora36 VM.
When I open VSCodium I get 2 Error messages:
I have also tried running the extension in VSCode but got the same errors.
Docker Version 20.10.17 is installed.
the loading icon on the button is stuck.
in the extension settings i get the following messages:

I am stuck here. How can I get to run it?

Hi @Malik ,

Welcome to our community! Feel free to explore other topics.

The messages on the extension settings are also present when the extension is working, so I don’t think they are related to your issue.

Given that you’re using Fedora 36 I suspect the problem might be related to OpenSSL: Our extension backend (called moses) uses OpenSSL 1.1, but the latest Fedora releases don’t have it by default anymore. Try installing it by running:

sudo dnf install openssl1.1

After that, try running VSCode again and see if the extension loads.

One final note: I’d recommend using VSCode for our extension, as we haven’t tested it on VSCodium and can’t guarantee that it will work there.

Best regards,
Lucas Akira

This worked. Thanks !

1 Like

Glad I was able to help!

Best regards,
Lucas Akira