Toradex Easy Installer Could not open device vid=0x1b67 pid=0x4000

Hello,

I used to follow the instruction there Toradex Easy Installer to get the Toradex Easys installer running on the target. It used to work properly without issue. But now It stopped working.

So from the cmd I got this after launching recovery-windows.bat.

config file <recovery\\\imx_usb.conf>
vid=0x15a2 pid=0x0054 file_name=mx6_usb_rom.conf
-> vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
-> vid=0x1b67 pid=0x4000 file_name=mx6_usb_sdp_uboot.conf
vid=0x15a2 pid=0x0061 file_name=mx6_usb_rom.conf
-> vid=0x1b67 pid=0x4fff file_name=mx6_usb_sdp_spl.conf
-> vid=0x1b67 pid=0x4000 file_name=mx6_usb_sdp_uboot.conf
vid=0x15a2 pid=0x0076 file_name=mx7_usb_rom.conf
-> vid=0x1b67 pid=0x4000 file_name=mx7_usb_sdp_uboot.conf
vid=0x15a2 pid=0x0080 file_name=mx6ull_usb_rom.conf
-> vid=0x1b67 pid=0x4000 file_name=mx6ull_usb_sdp_uboot.conf
config file <recovery\\\mx7_usb_rom.conf>
parse recovery\\\mx7_usb_rom.conf
Trying to open device vid=0x15a2 pid=0x0076
Interface 0 claimed
HAB security state: development mode (0x56787856)
== work item
filename u-boot.imx
load_size 0 bytes
load_addr 0x83f00000
dcd 1
clear_dcd 0
plug 0
jump_mode 2
jump_addr 0x00000000
== end work item
loading DCD table @0x910000

<<<-588, 1024 bytes>>>
succeeded (status 0x128a8a12)

loading binary file(u-boot.imx) to 877ff400, skip=0, fsize=55c00 type=aa

<<<351232, 351232 bytes>>>
succeeded (status 0x88888888)
jumping to 0x877ff400
config file <recovery\\\mx7_usb_sdp_uboot.conf>
parse recovery\\\mx7_usb_sdp_uboot.conf
Trying to open device vid=0x1b67 pid=0x4000.........................
Could not open device vid=0x1b67 pid=0x4000
Press any key to continue . . .

From the the serial console I got this:

U-Boot 2016.11-1.7.0+gf4db39ecb6 (Jul 31 2018 - 11:27:41 +0000)

CPU:   Freescale i.MX7D rev1.3 996 MHz (running at 792 MHz)
CPU:   Extended Commercial temperature grade (-20C to 105C) at 39C
Reset cause: POR
DRAM:  512 MiB
PMIC:  RN5T567 LSIVER=0x01 OTPVER=0x0d
MMC:   FSL_SDHC: 0
Using default environment

In:    serial
Out:   serial
Err:   serial
Model: Toradex Colibri iMX7S/D
Model: Toradex Colibri iMX7D
Serial Downloader recovery mode, using sdp command
Net:   FEC0
Error: FEC0 address not set.

Hit any key to stop autoboot:  0
SDP: initialize...
SDP: handle requests...

Many thanks in advance !

I checked with another computer running on Windows 7, so it might be a USB driver Issue. I’ll update the post, as soon as I get any workaround.

So is it working with Windows 7? Usually it should also work with Windows 10? Could you try to change the Cable and connect the carrier Board directly to your Host without any USB Hub?
Thanks.

So I tried with another computer with windows 7, it worked.
I started the recovery from Debian 9 running in a virtual machine running in the computer with win10, it also worked.

I assume it’s a windows 10 configuration problem. Using a debian vm running on Windows 10 is my final workaround.

Thank you jaski for your quick reply. I don’t want you to waste your time, so you can consider this issue solved.

Perfect that you found a solution. Thanks for the feedback.