[Ticket#2020112310000111] Problems with Colibri T20 + IRIS Rev2.0 + Window CE 7

We have been using the setup Colibri T20 + IRIS Rev 1.1 + Windows CE7 V2.1 for 3 years. Now, we are testing the new IRIS revision (Rev2.0) and found some problems:

  1. The SD Card was not recognized anymore. Reading the datasheet, Toradex removed some pull-ups and it is necessary to activate the colibri pull-ups. I tried to configure those pull-ups via ConfigBlockEditor.exe. I ran a .txt file as batch:

    setconfig boot.silent 1
    saveconfig boot
    setconfig gpio.bootconf = “[gpio_168] altfn=-1 [gpio_169] altfn=-1 [gpio_170] altfn=-1 [gpio_171] altfn=-1 pull=down [gpio_172] altfn=-1 [gpio_173] altfn=-1 [gpio_174] altfn=-1 [gpio_175] altfn=-1 [colibripin_49] pull=up”
    saveconfig gpio
    but the changes apparently were not saved. It seems like a bug. If I change via GPIOConfig.exe and remove and insert the SD Card it is recognized. So I update the Windows from 2.0 to 2.3 (the last stable version).

2.Trying the same steps in i) it worked! However, in some conditions our application was not running. I found the problem was the system language. In previous Windows versions, several languages were available, but in V2.2 and later, just english is available. I found out in the changelog in the Toradex website that this is an issue, but not planned to be fixed.

So, would I like to know if it is correct or I made some mistakes? If that is true, is there some workaround in order to make that setup work?

Hi @Renato ,

Thanks for the comments about the SD Card!

About the language issue, you may find the solution in this article.

Best regards,

Daniel Morais


I will try to follow the article.