The command "echo $OE_QMAKE_CXX" returns empty

Dear all,

Thank you in advance for your help thanks to this community.

I have an apalis imx6 development board and I am configuring the host machine (Linux Mint with kernel 4.13.0) to develop a Qt application to deploy to the target device. I read and followed the instructions at the following web pages:
https://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core)
https://developer.toradex.com/knowledge-base/how-to-set-up-qt-creator-to-cross-compile-for-embedded-linux

but when I type the command “echo $OE_QMAKE_CXX” (after source the libraries) I obtain an empty string. Do you have any suggestion?

Thank you very much
–BR

Hi Fabrizio

Which version of Bsp and QT are you compiling? Could you provide some information about your host? How did you setup the SDK?

In Qt5, $OE_QMAKE_CXX was changed to $CXX.

1 Like

I am compiling Qt4.8. My host machine has Linux Mint with kernel 4.13.0. I setup the SDK as described in the guides at the following links (on the Toradex web site):
https://developer.toradex.com/knowledge-base/board-support-package/openembedded-(core

https://developer.toradex.com/knowledge-base/how-to-set-up-qt-creator-to-cross-compile-for-embedded-linux

Thanks for your help!

Could you compile your application now?

First of all sorry for the delay, I tried right now and your “echo $CXX” command works (it is not empty) but I built target image for Qt4.8 (and not Qt5), with the command “bitbake -k qt4e-demo-image”. I don’t understand why it works, since in the documentation it is written that the correct command is “echo $OE_QMAKE_CXX”.
Then I installed the SDK, but when I try to run qmake, I cannot find qmake2 in the folder /usr/local/oecore-x86_64/sysroots/x86_64-angstromsdk-linux/usr/bin/. And so I cannot add the correct kit in Qt Versions in Build & Run Option.

Thank you for your help

Hi Fabrizio

First of all sorry for the delay
No problem.

I don’t understand why it works, since in the documentation it is written that the correct command is “echo $OE_QMAKE_CXX”.
Which Documentation. The developer article of setting up qt creator is old, there will be update of this article soon.

I cannot find qmake2 in the folder /usr/local/oecore-x86_64/sysroots/x86_64-angstromsdk-linux/usr/bin/. And so I cannot add the correct kit in Qt Versions in Build & Run Option.
qmake2 does not exist any more in the newer versions of Qt, so there will be an update of the article, however the build and run of application should work with the created SDK should. We tested this successfully.

Thank you so much for your help!

Ok I understand. I didn’t know that there will be an update about it, I thought that it was the correct procedure.

Qt runs successfully, but I don’t know how to set up the correct kit because in the tutorial qmake2 was mentioned, but it doesn’t exist anymore. Do you know how can I set it up correctly?

Thanks in advance for your precious help!
–BR

Hello
You can look for qmake instead of qmake2 and try this. I am building the image and the SDK with Qt4. Once this is done, I can give you more information.

Hi,

Ok thanks. I thought but I cannot find qmake inside the oecore folder.

Thank you very much for your help! I appreciate

hello
I build the the image bitbake -k angstrom-qt-x11-image -c populate_sdk and the SDK. Afterwards, I deployed the SDK. Qmake is located in folder ./sysroots/armv7at2hf-neon-angstrom-linux-gnueabi/usr/bin/ of the SDK.

Hi, sorry for my delay but I was out of office. I am really sorry.

I tried with your command, but I get this errorlink text

hi
have you done repo sync before compiling. Could you share your local.conf?
Thanks.

Hi,
I tried another time, deleting the oe-core folder and following the procedure. I get all these errors, I attached the log and the conf files. Thank you very much for your time and support, I really appreciate.

Hope to solve the issue!
BR
link text

hi

I don’t see any errors in this log. Could you share the log of last build placed in build/tmp-glibc/log/cooker/$MACHINE/ folder? Thanks.

Hi

My mistake. Sorry

link text

No Problem.
It seems, you are not able to connect to some Internet addresses. Please check your Internet or firewall settings and change them to get access to these Internet addresses.

Hi,

Sorry for my delays! It was a really busy period and I didn’t have time to investigate this problem.
I check the internet connection and it seems that the problem was during the downloading. However now I had another problem, I attached the log file. It is related to a package named libgl-mesa-dev: package libgl-imx-dev-1:6.2.2.p0-aarch32-r0.armv7at2hf-neon-mx6qdl requires libgl-mesa-dev, but none of the providers can be installed. Do you have any advise?
Thank you very much for your time and help!! I really appreciate!! link text

Hi

package libgl-imx-dev-1:6.2.2.p0-aarch32-r0.armv7at2hf-neon-mx6qdl requires libgl-mesa-dev

Please have a look here, the root cause and fix is the same.
Alternatively cherry-pick this commit into meta-toradex-nxp which basically does the same.

Max

Hi Max,

Thank you for your help!
I commented the line and I noticed that relaunching the shell script the log file in build/tmp-glibc/log/cooker/$MACHINE/ folder didn’t change. Is it right?
The procedure however didn’t pop-up any error, but when I try to select the qmake file in Qt a pop-up window appears and an error occurs: the format file is not correct. I followed the procedure on the website, but I still have the variable OE_QMAKE_CXX empty.

Thanks for your help in advance
Fabrizio