T30/WEC2013 running hot idle


I have received a new shipment of our product using a Colibri T30 module running WEC2013.
But they seem to run hot and eventually reboot (110 decrees)

The first shipment we got does not have this problem and they where the base for our master image.
The modules in the new shipment are updated with this master image.
But just standing on the desk idle in the shell, they do run very hot. We haven’t loaded the application yet.

I have attached picture showing version and temp/speed/load for a module running hot and one not running to hot.

The only different I can see is that the one running hot, the EMC clock is 400 MHz. In the other it is just 266 MHz.

Why does these two modules have different EMC clock speeds?
Is this why one of them are running to hot?

Would this also be the case running WEC7? We do use WEC7 on some of them to run some older software.

I have 50 units of this new shipment on stock. I havn’t tested all to see if they have the same issue, but 3 out of 3 are running to hot.

link text

I my add, that we have found one of the new produced, that is just running “semi” hot. Hotter than the previous once, but not so hot it reboots…

It is stable at around 75 decrees
The first we received is stable around 56 decrees

It also seems that when running the 1.4 WEC7 image it does not get so hot it reboots. It do get hot but “only” 75-76 decrees.

It also seems that running the WEC2013 v1.4 image there are NO overheating issues.
But there is with 2.0 beta2, beta3 and beta4.

What could be the difference from image version 1.4 and 2.0 beta’s that could lead to overheating?

I have measured the power consumption from the 1.4 and 2.0 version and the 2.0 used around 0.7 to 0.9 A more at 3.3 V !!!

The module are used in our own baseboard. Are some of the CPU pins used for something in the version 2,0,thereby using a lot of power if they are not connected to something??

When using the Iris carrier board it also runs to hot and reboot?!!!


The higher power consumption and heating is probably related to the increase RAM timings we introduced with the 2.0 images. As there is currently no Dynamic Frequency Switching (DFS) for the RAM clock, this results in a higher temperature / power consumption.

If you have no cooling option currently, you could reduce the RAM timings again from 800 to 533MHZ. This currently can only be done using NVFlash / Recovery mode. Open the *.cfg file for and add the following line bellow the [general] key like this:


Please get back to us, if this does not reduce the power consumption.

One other remark. Not all T30 modules having exactly the same power consumption. See also this question on the community.

Yes, It did help using a lower EMC clock.

Will there be EMC DFS in next release? And would it preventing the module to overheat?

Is this EMC ram timing option only possible using the recovery mode or would it also work with the UpdateTool?
I have 50 on stock that possible have some overheating problem. Would not prefer to have all those through a recovery mode option!

It will not be in 2.0 final release. It is planned for the next 2.1 beta release. See also issue 9381.
We are currently working on a update Tool that can also handle the emmc timing modification. I will check if we can already provide you a prerelease of this.

That could be nice…
Any idea when the 2.1 beta would be ready?

@TJO: It was originally planned in March (see also roadmap). We are currently a little behind schedule, probably it will be April.