T20 Ethernet Failure

I use the T20 running CE7 on a custom motherboard. I’ve had a few (very few) t20’s where the ethernet has failed. I have determined the problem is the T20 and not the motherboard because I have tested other T20’s in the motherboard and they have worked properly. I have also tested the bad T20 in the Iris Carrier Board and the ethernet did not work their either.

I have tried reflashing the os image and that has not helped either.

Has anyone experienced this and no of a fix?

This issue could be probably related to an issue 15455 we fixed in image 2.0 beta 2. Give it a try with the this image to see if this fixes also your issue. You can get the image from here.

If this does not solve your issue:

  • Do you check that on your carrier board or on one of our boards (Evaluation Board, Iris, …)?
  • Does this happen with every boot or only does it sometimes work and sometimes not.
  • Do you have something connected on the GPIO Y0 to Y3 (SODIMM 86, 88, 90, 92). Are these pins floating?

2.0b2 did not fix the ethernet issue.

I tested on the Iris Carrier Board and on our carrier board and the Ethernet did not work on either

This happens with every boot. I registered the device to my customer in January of 2014 and it worked fine until March of 2016. My customer just now returned the device to me. So, it worked fine for a little over 2 years then stopped working and has not worked since.

Out of about 600 T20’s I have in the field, I’ve had very few issues, so I’m not very concerned about this, but if there is a known fix I’d like to salvage the board.

I don’t have a lot of electronics knowledge for reading the schematics, but I only see one reference for a GPIO in the range you mentioned. It is GPIO 0 and the schematic doesn’t state it as Y, it only says “GPIO_000_MMCD” It goes to an SD Card slot which we don’t install any more, however there is a 51 OHM resistor on that GPIO.

Thanks for checking. Currently, this sounds like there is an issue with the specific module. If you want, just send one or two of the modules using our RMA process. So we can do some further analysis. You can start the RMA process using this form.

About your GPIO question: No, the MMCD (Card Detect) should not be the issue.

Thanks Samuel,
The module is out of warranty and it hasn’t happened much, so I’m not looking for or expecting any sort of replacement, but if you are wanting to look at the module yourself to determine the problem for your benefit, I would be glad to return it.

Thanks again for all your help.

@wesvic: Let us keep it like that. If you find this issue popping up more often, we should have a closer look on that and investigate one of your modules. Please keep an eye on that issue and let us know if you see this more often.