T20 CE7 image v2.2b4 failed to load splashscreen bmz file

with CE7 image 2.2b4 i am not able to load splashscreen with update tool v6.0.16 or 6.0.17.
it does work on image 2.2b2.

Dear @compu

I was not able to reproduce the problem.
Could you please send me

  • your splashscreen file
    If you want to keep it private, mark the comment as viewable by moderators and the original poster
  • a log of your bootloader display timings
    (In the bootloader command line, type set ss)

Regards, Andy

Dear @compu

I tested using the Update Tool with your splashscreen that you sent me, it gets flashed correctly.
However, initially I just saw a black display, because of a wrongly configured resolution.

By default the display resolution is configured to be 640x480 pixels, your splashscreen has a size of 800x480 pixels. If the splashscreen is larger than the configured resolution, Eboot does not show it.

What you need to do is to configure the display timings in the bootloader config block. Details are explained in the following Developer Page article:

Regards, Andy

Dear Andy,
I am still not able to load the splashscreen though i have no problem to load this splashscreen with v2.2b2 and v2.2b3. Here are the steps:

  • load CE7 v2.2b4 image to T20 on V3.2A evaluation board
  • T20_tweak set screen to 800x480 (EDT_ET070080_800x480, demo screen from Toradex), see attached pictures.
    Note: did not need to do anything with ConfigBlockEditor for v2.2b2 and v2.2b3.
  • update splashscren and reboot
  • after reboot the spashscreen flash once and disappears.

what did i do wrong?

Dear @compu

To analyze the problem, I would really appreciate to get the output of the serial port when entering the command set ss in the bootloader command line,

Regards, Andy

Hi Andy, see attached.link text

Dear @compu

I think I found the problem, but let’s first clarify a few things:

  1. You mentioned that you are not able to load splashscreen with update tool v6.0.16 or 6.0.17.
    I assume you are able to load the splashscreen (the Update Tool does not report any error). Please confirm.
  2. I assume the error you wanted to report is: Instead of the splash screen, the display remains black. Please confirm.
  3. If my assumptions above are correct, then the problem is not related to your splashscreen. Even if you take a factory-new module with the original splash screen, then configure the display timings with set ss ..., the display reamains black instead of showing the splashscreen. Please confirm.

I suspect that the display brightness is configured to the minimum, so the screen remains black.We did a modification in bootloader V2.2b4 which would explain this behavior, it is documented as Issue #29128.

The intention of the display power signals is:

  • SS.DISP_GPIO controls the power to the display electronics
  • SS.BL_GPIO turns on/off the display backlight, and controls its brightness

For most displays DISP_GPIO=1 means full brightness. However, for your particular display, DISP_GPIO=0 means full brightness.
I don’t know your circuit, but I assume you used two different GPIOs (GPIO 156 = GPIO T4 for brightness, another GPIO for display power).

What you need to do is:

  1. Configure the GPIO number for ss.disp.gpio to match your hardware
  2. Configure ss.bl_pol=0 to set the display to full brightness when on

Regards, Andy

  1. i am able to load the splashscreen with update too v6.0.16 or 6.0.17 without getting any error msg.
  2. After reboot the loaded splashscreen flashes for a split second, and them goes back to default CE screen (not black screen)
  3. i have not tried with a factory-new module yet.

Dear @compu

Please let me know the results of my suggestions above. If it does not help, please send me the circuit diagram showing how your DISP_GPIO and BL_GPIO signals are wired, along with the updated output of set ss.

Regards, Andy

Hi Andy, to me the GPIO and display brightness is configured properly because it works with default Toardex splashscreen perfectly except it does not display the splashscreen. And also it works perfectly with CE7 image v2.2b2 and v2.2b3.

Dear @compu

As mentioned above, I need at least the output of set ss in order to help you.

Regards, Andy

Hi Andy,
please see attached set ss.link text

Dear @compu

As I don’t have all the information about your system I need to make some assumptions again

  • I assume you are using the EDT ET070080 display?
    Please confirm (or clarify)
  • I guess you connected the display pin 6 (PWM_A) to SODIMM 59?
    Please confirm (or clarify)
  • I guess you connected the display pin 5 (BL_ON) to SODIMM pin 71?
    Please confirm (or clarify)
  • I guess you did not take any measures to configure pin 6 to the appropriate level?
    Please confirm (or clarify)

If my assumptions above are all correct, then the following additional settings in the bootloader config block are the solution:

set ss.bl_gpio 12
set ss.bl_pol 0
save ss

It assures that the display pin 6 is configured to 0V (full brightness)

Regards, Andy

After our phone call I edited your original question to add the hardware configuration details

  • Colibri Evaluation Board V3.2
    • So your display pin 6 (PWM_A) is actually connected to SODIMM 59, and
    • your display pin 5 (BL_ON) is actually connected to SODIMM 71

Dear @compu

Now that I know you’re using an Evaluation Board V3.2A and the EDT ET070080 display, I can give you more precise hints:

Step 1

Start with a minimum change from the factory default settings:

Make sure you start with a module in factory default configuration (default Toradex splashscreen loaded, not your own.

Enter the bootloader menu and type the following commands:

clear gpio
clear ss
set ss.bl_gpio 12
set ss.bl_pol 0
save ss

Reset the system and enter the bootloader menu again.
You should see the splash screen (however, there might be a colored stripe on the right end of the display, because the resolution is not yet correctly set up)

If you don’t see the splash screen, please measure the following voltages on the Evaluation Board:

  • X7 pin 46 (SODIMM pin 71, BL_ON).
    Expected: 3.3V
  • X12 pin 26 (SODIMM pin 59, PWM_A)
    Expected: 0V

If you still see no splashscreen, I suspect that there was something wrong with programming the splashscreen. Please note: If the splashscreen is larger than the configured resolution, you will see a black image only.

Step 2

Once the splash screen is visible, let’s configure the correct resolution and timings:

Enter the bootloader menu again, and type the following commands:

clear gpio
clear ss
set ss.bl_gpio 12
set ss.bl_pol 0
set ss.width 800
set ss.pclk 33230769
set ss.hsw 128
set ss.blw 88
set ss.elw 40
set ss.hsp 1
set ss.vsp 1
set ss.pcp 1
set ss.acb 1
save ss

Let me know about your results.

Regards, Andy

Dear @compu

I configured my T20 to work properly with the EDT display, and made a full system backup using the Update Tool 6.0.17.
You can download the files and apply it to your module.

Regards, Andy

loaded CE7 v2.4b image first, and rebooted.
Getting an error message ‘UDLDoUpdate:NvFlashError’ when loading edt800x480.cfg.

yes. i always have the latest update tool on an USB memory stick, and updated from there.

Dear @compu
Did you copy all the files edt800x480.* as well as the UpdateTool onto an external storage (USB or SD) and update from there?
Regards, Andy

The update tool generated a log file on the USB stick. Please send me this log.