System Information Library Crash

When udating to the 2.1 library i have noticed that the sysinfo no longer works. I have changed my code to match the demos and still experience the same problem. When calling

    printf("\tBspVersion\t= ");
    ret = Sys_GetConfigInt(hSys, L"BspVersion", &BspVersion.Val);

I get the error saying it hit a break point. I will try to get more information but i went back to the old libraries to check it was fine before and now i can’t get it to run at all with new libraries. It doesn’t get into my code. I just thought i would see if you had the same issue.

I am using visual studio 2015

Dear @stephen.digi

It would be helpful if you can connect a terminal to the UART1 port, and activate the debug output through the bootloader menu:

>set dbg.serial 1
>save dbg

On the terminal it will show you a precise source code line where the error occured.

I have fixed my problem now. I worked out what was wrong once serial debug was enabled. Was not initializing handle correctly not sure why it worked with old libraries though.